9 顺序表元素移动(OJ通过)

描述:

已知线性表(a1 a2 a3 …an)按顺序存于内存,每个元素都是整数,试设计用最少时间把所有值为负数的元素移到全部正数值元素前边的算法:

例:(x,-x,-x,x,x,-x …x)变为(-x,-x,-x…x,x,x)。
输入:
第一行输入顺序表长度 n
第二行输入 n 个元素
输出:
输出移动后的顺序表元素

输入样例

6
1 2 3 -4 -5 -6

输出样例

-4 -5 -6 1 2 3

Code:

#include "stdio.h"
#include "stdlib.h"

void sort(int *A,int n)
{
    int i,j,temp;
    temp=i=j=0;
    int *a,*b;
    a=(int *) malloc(n*sizeof (int));
    b=(int *) malloc(n*sizeof (int));
    while(i+j<n)
    {
        if(A[temp]>=0)
        {
            a[i++]=A[temp];
        }
        else
        {
            b[j++]=A[temp];
        }
        temp++;
    }
    temp=0;
    while (temp<j)
    {
        printf("%d ",b[temp++]);
    }
    temp=0;
    while (temp<i)
    {
        printf("%d ",a[temp++]);
    }

}

int main() {
    int *A,size,i=0;
    scanf("%d",&size);
    A=(int *) malloc(size*sizeof (int));

    while (i < size)
    {
        scanf("%d",&A[i]);
        i++;
    }

    sort(A, size);
    free(A);
    return 0;
}

评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值