14 栈的运用(OJ通过)

描述:

构建一个栈,根据指令进行相关操作。

指令 1,输入一个整数 num;指令 2,输出栈顶元素;指令 3,弹出栈顶元素。
输入:
输入一个整数 n 和栈的大小 m,然后输入 n 组指令。
输出:
注意:如果栈满,输出 full;如果栈空,输出 empty;否则,正常输出栈顶元素;

每个输出用回车间隔。

输入样例1

3 2
1 123
2
3

输出样例1

123

输入样例2

8 2
1 123
1 234
1
3
3
3
1 555
2

输出样例2

full
empty
555

Code:

#include "stdio.h"
#include "stdlib.h"
#define true 1
#define false 0

int size;
typedef int Status;
typedef struct
{
    int *top;
    int *base;
    int Stacksize;
}sqStack;

void InitStack(sqStack *s)
{
    s->base=malloc(size*sizeof(char));
    if(!s->base)
    {
        exit(0);
    }
    s->Stacksize=size;
    s->top=s->base;
}

void Push(sqStack *s,int ch)
{
    *s->top++=ch;
}

void Pop(sqStack *s,int *ch)
{
    *ch=*--s->top;
}

Status stackFull(sqStack s)
{
    if(s.top-s.base==size)
    {
        return true;
    }
    else
    {
        return false;
    }
}

Status stackEmpty(sqStack s)
{
    if(s.top==s.base)
    {
        return true;
    }
    else
    {
        return false;
    }
}

void PrintTop(sqStack s)
{
    printf("%d\n",*--s.top);
}

int main()
{
    int times,i;
    sqStack s;
    scanf("%d %d",&times,&size);
    InitStack(&s);
    for(i=1;i<=times;i++)
    {
        int choice;
        scanf("%d",&choice);
        if(choice==1)
        {
            int temp;
            if(stackFull(s))
            {
                printf("full\n");
                continue;
            }
            else
            {
                scanf("%d",&temp);
                Push(&s,temp);
            }
        }
        else if(choice==2)
        {
            int ch;
            if(stackEmpty(s))
            {
                printf("empty\n");
            }
            else
            {
                PrintTop(s);
            }
        }
        else
        {
            int ch;
            if(stackEmpty(s))
            {
                printf("empty\n");
            }
            else
            {
                Pop(&s,&ch);
            }
        }
    }

    return 0;
}

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值