hdu4310 Hero 思路及题解

Problem Description

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input

The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output

Output one line for each test, indicates the minimum HP loss.

Sample Input

1
10 2
2
100 1
1 100

Sample Output

20
201

思路

首先理解题意,每回合可以选择一名敌方英雄进行攻击,他的生命值减少1,也就是我们的攻击力为1,每个英雄都有hp和dps,要求选择最佳策略以最小的 HP 损失杀死所有敌方英雄。这样就可以先想到,要受到伤害最小,也就是先判断每个英雄的杀伤力(攻击力/血量)如何,杀伤力越大,就是我们先要集火的目标,这里也就是用到了贪心的思想,局部最优解。具体实现呢,首先输入用例,我这里用了一个结构体enemy来定义敌人,每个结构体的属性有hp,attack,rate这三个,然后这里通过sort进行排序,将杀伤力大的放前面,最先集火,同时用一个days变量记录已经攻击的时间,因为攻击力为1,所以这里忽略了除以1。再用lose记录失去的血量,此时lose即为最小失去的血量,也就是题解。

代码

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 21;
struct enemy
{
	double attack;		//攻击力
	double hp;			// 血量
	double rate;		//杀伤力(攻击力/血量)
}enemies[maxn];

bool cmp(enemy e1, enemy e2)
{
	return e1.rate > e2.rate;
}
int main()
{
	int N;
	
	while (cin >> N)
	{
		//进行初始化
		memset(enemies, 0, sizeof(enemies));
		for (int i = 0; i < N; ++i)
		{
			cin >> enemies[i].attack >> enemies[i].hp;
			enemies[i].rate = enemies[i].attack/ enemies[i].hp;
			sort(enemies, enemies + N, cmp);
		}

		// 记录失去的血量,以及当前时间
		int lose = 0,days=0;
		for (int i = 0; i < N; ++i)
		{
			days = days + enemies[i].hp;					//每次攻击为1,攻击hp次
			lose = lose + enemies[i].attack * days;	//失去的血量
		}
		cout << lose << endl;
	}

	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值