1038. 统计同成绩学生

本题要求读入N名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:

输入在第1行给出不超过105的正整数N,即学生总人数。随后1行给出N名学生的百分制整数成绩,中间以空格分隔。最后1行给出要查询的分数个数K(不超过N的正整数),随后是K个分数,中间以空格分隔。

输出格式:

在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。

输入样例:
10
60 75 90 55 75 99 82 90 75 50
3 75 90 88
输出样例:
3 2 0

==========================================================================================
思路:
暴力应该就别想了。
使用数组即可,下标是成绩,对应值是人数。【这里由于我当时在练习STL所以使用了map】
#include <iostream>
#include <stdio.h>
#include <iomanip>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
using namespace std;

int main()
{
    map<int,int> stu;
    int n,temp;
    cin>>n;
    while(n--)
    {
        cin>>temp;
        stu[temp]++;
    }
    int m;
    cin>>m;
    while(m--)
    {
        cin>>temp;
        cout<<stu[temp];
        if(m>0)
            cout<<" ";
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值