PAT 1036 Boys vs Girls (25分)

PAT 1036 Boys vs Girls (25分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade ​F​​−grade M. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

**题意:**给出N个同学的信息,输出女生中最高分数获得者的信息和男生中最低分数获得者的信息,并输出它们的差。如果不存在男生或女生,则在对应获得者信息处输出Absent,同时分数差处输出NA。

#include<cstdio>
struct student{
    char name[20];
    char id[20];
    int score;
}stu,Max_F,Min_M;
int main(){
    int n;
    char sex;//定义性别
    Max_F.score=-1;//初始化女生最高分为-1
    Min_M.score=101;//初始化男生最低分为101
    scanf("%d",&n);//输入学生个数
    for(int i=0;i<n;i++){
        scanf("%s %c %s %d",stu.name,&sex,stu.id,&stu.score);
        if(sex=='F'&&stu.score>Max_F.score){//女生且分数高于当前最大值
                Max_F=stu;//更新女生最大值
        }
        else if(sex=='M'&&stu.score<Min_M.score){//男生且分数低于当前最小值
                Min_M=stu;//更新男生最小值
        }
    }
    if(Max_F.score==-1) printf("Absent\n");//只要有女生就不会为Absent
    else printf("%s %s\n",Max_F.name,Max_F.id);
    if(Min_M.score==101) printf("Absent\n");//没有男生
    else printf("%s %s\n",Min_M.name,Min_M.id);
    if(Max_F.score==-1||Min_M.score==101) printf("NA\n");//没有女生或男生,只要有就一定有分数,有分数就一定有差值
    else printf("%d\n",Max_F.score-Min_M.score);//输出差值
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值