HDU 5742 It's All In The Mind(贪心?)

Problem Description

Professor Zhang has a number sequence a1,a2,...,an. However, the sequence is not complete and some elements are missing. Fortunately, Professor Zhang remembers some properties of the sequence:

1. For every i∈{1,2,...,n}, 0≤ai≤100.
2. The sequence is non-increasing, i.e. a1≥a2≥...≥an.
3. The sum of all elements in the sequence is not zero.

Professor Zhang wants to know the maximum value of a1+a2∑ni=1ai among all the possible sequences.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains two integers n and m (2≤n≤100,0≤m≤n) -- the length of the sequence and the number of known elements.

In the next m lines, each contains two integers xi and yi (1≤xi≤n,0≤yi≤100,xi<xi+1,yi≥yi+1), indicating that axi=yi.

Output

For each test case, output the answer as an irreducible fraction "p/q", where p, q are integers, q>0.

Sample Input

2
2 0
3 1
3 1

Sample Output

1/1
200/201

观察给出的分式可知,a1+a2越大越好,其余的越小越好,处理下a1a2剩下的贪心按小的取就行

代码如下:

#include <bits/stdc++.h>
using namespace std;
int a[101];
int main(){
    int t, n, m, xi, yi;
    cin >> t;
    while(t--){
        memset(a,-1,sizeof(a));
        cin >> n >> m;
        while(m--){
            cin >> xi >> yi;
            a[xi] = yi;
        }
        int tmp = (a[n] == -1) ? 0 : a[n];
        ans =0,a12 = 0;
        for(int i = n; i >= 3; i--){
            if(a[i] != -1) tmp = a[i];
            ans+=tmp;
        }
        if(a[1] ==  -1 && a[2] == -1) a12+=200;
        else if(a[1] == -1) a12+=a[2]+100;
        else if(a[2] == -1) a12+=a[1]*2;
        else a12 += a[1]+a[2];
        ans += a12;
        int tp = __gcd(ans, a12);
        cout << a12/tp << '/' << ans/tp << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值