HDU 2509 Be the Winner(Anti-Nim)

Problem Description
Let’s consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example “@@@” can be turned into “@@” or “@” or “@ @”(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

Output
If a winning strategies can be found, print a single line with “Yes”, otherwise print “No”.

Sample Input
2
2 2
1
3

Sample Output
No
Yes

拿最后一个的人输,anti-nim;

这题的关键在于可以把一堆得苹果拿成两堆的情况(使这堆不再连续),所以先手必胜的情况为:

①所有堆都为1且nim和为0;

②有一堆及以上不为1且nim和不为0;

对于第二个条件解释如下:

①若只有一堆不为1,可以把这堆拿成一堆或两堆1,并且nim和为1;
②若大于一堆不为1,可以操作把nim和变为0且还剩有知道一堆不为1。

ac代码:

#include <bits/stdc++.h>

using namespace std;

#define rep(i,a,n) for(int i = (a); i < (n); i++)
#define per(i,a,n) for(int i = (n)-1; i >= (a); i--)
#define clr(arr,val) memset(arr, val, sizeof(arr))
#define mp make_pair
#define pb push_back
#define fi first
#define se second
#define pi acos(-1)
typedef pair<int, int> pii;
typedef long long LL;
const LL mod = 1000000007;
const double eps = 1e-8;

int main(int argc, char const *argv[]) {
    int n, tmp;
    while (cin >> n) {
        bool f = true;
        int ans = 0;
        rep(i, 0, n){
            scanf("%d", &tmp);
            ans ^= tmp;
            if(tmp > 1) f = false;
        }
        if(f) puts(ans?"NO":"Yes");
        else puts(ans?"Yes":"No");
    }
    return 0;
}

还是得细细琢磨集训队论文啊2333

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值