HDU 5754 Life Winner Bo(博弈)

Problem Description
Bo is a “Life Winner”.He likes playing chessboard games with his girlfriend G.

The size of the chessboard is N×M.The top left corner is numbered(1,1) and the lower right corner is numberd (N,M).

For each game,Bo and G take turns moving a chesspiece(Bo first).At first,the chesspiece is located at (1,1).And the winner is the person who first moves the chesspiece to (N,M).At one point,if the chess can’t be moved and it isn’t located at (N,M),they end in a draw.

In general,the chesspiece can only be moved right or down.Formally,suppose it is located at (x,y),it can be moved to the next point (x′,y′) only if x′≥x and y′≥y.Also it can’t be moved to the outside of chessboard.

Besides,There are four kinds of chess(They have movement rules respectively).

1.king.

2.rook(castle).

3.knight.

4.queen.

(The movement rule is as same as the chess.)

For each type of chess,you should find out that who will win the game if they both play in an optimal strategy.

Print the winner’s name(“B” or “G”) or “D” if nobody wins the game.

Input
In the first line,there is a number T as a case number.

In the next T lines,there are three numbers type,N and M.

“type” means the kind of the chess.

T≤1000,2≤N,M≤1000,1≤type≤4

Output
For each question,print the answer.

Sample Input
4
1 5 5
2 5 5
3 5 5
4 5 5

Sample Output
G
G
D
B

挺坑的博弈题,可以强行平局;

下面分析四种棋子的情况:

King:n和m只要有一个偶数就Bo就能赢,画个棋盘反推一下就行;

Cook:n==m时G赢,否则B赢,巴什博弈画个图图反推一下就能发现只有对角线是P状态,剩下全是N状态;

Knight:这个可以强行平手,比赛时没做出来就是因为没想到这个,好气啊。。我真的坑。。。      
画个图可以发现P状态都是在正方形对角线上,
G想稳赢就必需n==m并且n模3余1(画图推一推就知道);
在剩下的情况中,B要想稳赢就要满足 abs(n-m) == 1并且n和m模3都不能为1;
(这个只要画个图吧N状态和P状态画出来就明白了,只有围绕在正方形对角线的N位置和P位置才能确保谁赢,
别的情况下劣势的一方都可以强行平手)

Queue:根据规则或画个图模拟一下都能发现,n--,m--后,G能赢的位置都是威佐夫博弈的奇异态,算下是否满足威佐夫博弈即可

ac代码:

#include <bits/stdc++.h>
#define clr(arr,val) memset(arr,val,sizeof(arr))
#define rep(i,j,k) for(int i = j; i <= k; i++)
using namespace std;
int n, m, t, ty;
int main(){
    cin >> t;
    while(t--){
        bool f = false;
        bool d = true;
        scanf("%d%d%d",&ty,&n,&m);
        if(ty == 1){
            if(n%2==0||m%2==0) f = true;
        }
        if(ty == 2){
            if(n!=m) f = true;
        }
        if(ty == 3){
            if(n == m&&n%3==1) f = false;
            else {
                if(abs(n-m) == 1 && n%3 != 1 && m%3 != 1){
                    f = true;
                }
                else d = false;
            }
        }
        if(ty == 4){
            n--,m--;
            double k = (sqrt(5)-1.0)/2.0;
            if(n > m) swap(n,m);
            int j = n*k;
            if(n!=(int)(j*(k+1)))j++;
            if(n+j!=m) f = true;
        }
        if(!d) puts("D");
        else puts(f?"B":"G");
    }
    return 0;
}
利用 TensorFlow 训练自己的目标识别器。本文内容来自于我的毕业设计,基于 TensorFlow 1.15.0,其他 TensorFlow 版本运行可能存在问题。.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值