POJ 2305

76 篇文章 0 订阅
9 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4429 Accepted: 1869

Description

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.

Input

Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.

Output

For each test case, print a line giving p mod m as a base-b integer.

Sample Input

2 1100 101
10 123456789123456789123456789 1000
0

Sample Output

10
789

Source


训练下java的大数,来自 MMchen

题意:在 b 进制下,算出 p mod m



2305Accepted5916K829MSJava527B2013-05-09 11:35:20 

import java.math.*;
import java.util.*;
public class Main {
	public static void main(String args[]){
		int base;
		Scanner cin = new Scanner(System.in);
		while(cin.hasNextInt()){
			base = cin.nextInt();
			if(base == 0) break;
			
			BigInteger p, m;
			p = cin.nextBigInteger(base); //自动转换为 base进制读入
			m = cin.nextBigInteger(base);
			
			BigInteger a;
			String str;
			a = p.mod(m); // a = p%m 注意此时结果为 10 进制
			str = a.toString(base); //将十进制 a 转换成  base 进制字符串

			System.out.println(str);
		}
	}

}


         

2305Accepted5916K829MSJava527B2013-05-09 11:35:20 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值