【HDOJ 5800】To My Girlfriend(DP)

【HDOJ 5800】To My Girlfriend(DP)

To My Girlfriend

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 157    Accepted Submission(s): 49

Problem Description
Dear Guo

I never forget the moment I met with you.You carefully asked me: “I have a very difficult problem. Can you teach me?”.I replied with a smile, “of course”.”I have n items, their weight was a[i]”,you said,”Let’s define f(i,j,k,l,m) to be the number of the subset of the weight of n items was m in total and has No.i and No.j items without No.k and No.l items.”“And then,” I asked.You said:”I want to know

ni=1nj=1nk=1nl=1sm=1f(i,j,k,l,m)(i,j,k,laredifferent)

Sincerely yours,
Liao

Input
The first line of input contains an integer T indicating the number of test cases.
Each case contains 2 integers (4n1000,1s1000) . The next line contains n numbers: (1ai1000).

Output
Each case print the only number — the number of her would modulo 109+7 (both Liao and Guo like the number).

Sample Input
2
4 4
1 2 3 4
4 4
1 2 3 4

Sample Output
8
8

Author
UESTC

Source
2016 Multi-University Training Contest 6

题目大意:
n个数。对于s,查询
ni=1nj=1nk=1nl=1sm=1f(i,j,k,l,m)(i,j,k,laredifferent)
f(i,j,k,l,m) 表示集合中必须含有 ai aj ,必须没有 ak al ,和为m的集合个数。

直接上DP数组定义:
dp[i][j][k][l] 表示对于前i个数,能选择出的和为j,一定含有k个元素,一定不含l个元素,的集合个数。
O(ns2^3)四层循环跑一下就行了。具体转移方程写完for里面就好推了。

赛后交MLE了一发。居然忘了滚动数组优化了。罪过啊~~~

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread(ch) freopen(ch,"r",stdin)
#define fwrite(ch) freopen(ch,"w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;

int dp[2][1001][3][3];

int main()
{
    //fread("");
    //fwrite("");

    int t,n,s;

    scanf("%d",&t);

    while(t--)
    {
        scanf("%d%d",&n,&s);
        int x;

        memset(dp[0],0,sizeof(dp[0]));
        dp[0][0][0][0] = 1;
        int pos = 1;
        for(int i = 1; i <= n; ++i)
        {
            scanf("%d",&x);
            memset(dp[pos],0,sizeof(dp[pos]));
            for(int j = 0; j <= s; ++j)
            {
                for(int k = 0; k <= 2; ++k)
                {
                    for(int r = 0; r <= 2; ++r)
                    {
                        //集合不包含当前元素,也不把当前元素作为不可选
                        dp[pos][j][k][r] = (dp[pos][j][k][r]+dp[pos^1][j][k][r])%mod;
                        //集合不包含当前元素,把当前元素作为不可选
                        if(r) dp[pos][j][k][r] = (dp[pos][j][k][r]+dp[pos^1][j][k][r-1])%mod;
                        if(j+x > s) continue;
                        //集合包含当前元素,也不把当前元素作为必选
                        dp[pos][j+x][k][r] = dp[pos^1][j][k][r];
                        //集合包含当前元素,把当前元素作为必选
                        if(k) dp[pos][j+x][k][r] = (dp[pos][j+x][k][r]+dp[pos^1][j][k-1][r])%mod;
                    }
                }
            }
            pos ^= 1;
        }

        pos ^= 1;
        LL ans = 0;
        for(int i = 1; i <= s; ++i)
        {
            ans = (ans+dp[pos][i][2][2])%mod;
        }
        printf("%lld\n",(ans*4)%mod);
    }

    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值