hdoj2577 How to Type ( DP水题 )

题目:http://acm.hdu.edu.cn/showproblem.php?pid=2577

How to Type

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 
Sample Input
  
  
3 Pirates HDUacm HDUACM
 
Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
题意:

给出一个由大小写字母写成的字符串,起初键盘上Caps Look是关的,问最少要敲多少下键可以把字符串输入完,输入结束时Caps Look要是关的。

中途可以打开Caps Look键,也可以用Shift键来转换大小写。

思路:

dp[i][0]表示第i个字母输入完后共敲键的次数,且此时Caps Look要是关的; dp[i][1]表示第i个字母输入完后共敲键的次数,且此时Caps Look要是开的;

#include<stdio.h>
#include<string.h>
char a[111];
int dp[111][2];
int min(int x,int y)
{
    if(x<y)return x;
    return y;
}
int main()
{
    int t,i,j,len;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",a+1);
        len=strlen(a+1);
          if(a[1]>='a'&&a[1]<='z')
          {
              dp[1][0]=1;
              dp[1][1]=2;
          }
          else
          {
              dp[1][0]=2;
              dp[1][1]=2;
          }
        for(i=2;i<=len;i++)
        {
            if(a[i]>='a'&&a[i]<='z')
            {
                dp[i][0]=min(dp[i-1][0]+1,dp[i-1][1]+2);
                dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+2);
            }
            else
            {
                 dp[i][0]=min(dp[i-1][0]+2,dp[i-1][1]+2);
                 dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+1);
            }
        }
        printf("%d\n",min(dp[len][0],dp[len][1]+1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值