2-7 一元多项式求导 (20分)-HBU DS

2-7 一元多项式求导 (20分)-HBU DS

设计函数求一元多项式的导数。

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

注意

特殊情况:数据只有常数的情况。

#include <iostream>
using namespace std;
typedef struct Node *List;
struct Node
{
    int a;
    int e;
    List next;
};
List Read();
int main()
{
    List L = Read();
    List temp = L->next;
    if(temp->e==0)
        printf("0 0");
    else{
    for (int i = 0; temp && temp->e != 0; i++)
    {
        if (i != 0)
            printf(" ");
        printf("%d %d", temp->a * temp->e, temp->e - 1);
        temp = temp->next;
    }
    }
}
List Read()
{
    List L = (List)malloc(sizeof(Node)), temp, s;
    L->next = NULL;
    temp = L;
    int a, e;
    while (cin >> a >> e)
    {
        s = (List)malloc(sizeof(Node));
        s->a = a;
        s->e = e;
        s->next = NULL;

        temp->next = s;
        temp = s;
    }
    return L;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值