最大子序列和问题 ChenDS

最大子序列和问题

1

01-复杂度1 最大子列和问题 (20分)

给定K个整数组成的序列{ N1, N2, …, N**K },“连续子列”被定义为{ N**i, N**i+1, …, N**j },其中 1≤ijK。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。

本题旨在测试各种不同的算法在各种数据情况下的表现。各组测试数据特点如下:

  • 数据1:与样例等价,测试基本正确性;
  • 数据2:102个随机整数;
  • 数据3:103个随机整数;
  • 数据4:104个随机整数;
  • 数据5:105个随机整数;

输入格式:

输入第1行给出正整数K (≤100000);第2行给出K个整数,其间以空格分隔。

输出格式:

在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。

输入样例:

6
-2 11 -4 13 -5 -2

输出样例:

20

思路

就是mooc上的在线算法。

代码

#include <iostream>
using namespace std;
int main()
{
    int n;
    cin >> n;
    int maxSum = 0;
    int cur;
    int thisSum = 0;
    while (n--)
    {
        cin >> cur;
        thisSum += cur;
        if (thisSum > 0)
        {
            if (thisSum > maxSum)
                maxSum = thisSum;
        }
        else
            thisSum = 0;
    }
    cout << maxSum;
}

2-改变增加需要输出最大子序列的两头

01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

注意

需要考虑特殊情况:全是负数,或者有零有负数。全是负数的时候,输出的最大子列的两端根据题意要输出序列两端。还有有0还有负数的情况,这个时候的最大值也是0,但是输出的子序列两端不应该是整个序列的两端,应该是“0”序列的两端。

正常情况即maxSum是正数的情况下很好区分,如何区分全是负数以及有负有0的情况?

这里通过设置 maxSum=-1 以及 if(thisSum>=0) 来区分。如果全是负数,那么maxSum的值就不会改变,就是-1;而如果有一个0的话,那么thisSum就会为0,就会>=0,就会把maxSum的值为0。

代码1_先放到数组

#include <iostream>
using namespace std;
int main()
{
    int data[10005];
    int total;
    cin >> total;
    for (int i = 0; i < total; ++i)
        cin >> data[i];
    int maxSum = -1, thisSum = 0;
    int left = 0, right = 0, trueleft = 0;
    for (int i = 0; i < total; ++i)
    {
        thisSum += data[i];
        if (thisSum >= 0)
        {
            if (thisSum > maxSum)
            {
                maxSum = thisSum;
                trueleft = left;
                right = i;
            }
        }
        else
        {
            thisSum = 0;
            left = i + 1;
        }
    }
    if (maxSum>=0)
        printf("%d %d %d", maxSum, data[trueleft], data[right]);
    else
        printf("0 %d %d", data[0], data[total - 1]);
}

代码2_输入一个判断一个

#include <iostream>
using namespace std;
int main()
{
    int cur;
    int total;
    cin >> total;
    int begin, end;
    int maxSum = -1, thisSum = 0;
    int left = 0, right = 0, trueleft = 0;
    bool isLeftBeNextNum = true;
    //如果判断thisSum<0那么left就从下一个输入开始;初始值为true,是为第一个left为第一个输入
    for (int i = 0; i < total; ++i)
    {
        cin >> cur;
        if (i == 0)
            begin = cur;
        if (i == total - 1)
            end = cur;
        if (isLeftBeNextNum)
        {
            left = cur;
            isLeftBeNextNum = false;
        }
        thisSum += cur;
        if (thisSum >= 0)
        {
            if (thisSum > maxSum)
            {
                maxSum = thisSum;
                trueleft = left;
                right = cur;
            }
        }
        else
        {
            thisSum = 0;
            isLeftBeNextNum = true;
        }
    }
    if (maxSum >= 0)
        printf("%d %d %d", maxSum, trueleft, right);
    else
        printf("0 %d %d", begin, end);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值