1007 Maximum Subsequence Sum (25分) PAT 甲级

1007 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

~

浙大数据结构mooc遇到过这种题,在线算法。

如果遇到测试点4 5的问题,注意边界情况。(详情看代码前几行)

代码

// 注意 边界情况
// 一种全是负数 输出 first和last
// 一种有一个 0
// 区分一个0 和全是负数 就将maxSum设置为负数 可以区分他们

#include <iostream>
using namespace std;
int main()
{
    int N;
    cin >> N;
    int left = 0, right = 0, tmpleft = 0;
    bool nextBeTmpLeft = true;
    int maxSum = -1;
    int thisSum = 0;
    int first, last;
    for (int i = 0; i < N; ++i)
    {

        int cur;
        cin >> cur;
        if (i == 0)
            first = cur;
        else if (i == N - 1)
            last = cur;
        thisSum += cur;
        if (nextBeTmpLeft)
        {
            tmpleft = cur;
            nextBeTmpLeft = false;
        }
        if (thisSum > maxSum)
        {
            maxSum = thisSum;
            right = cur;
            left = tmpleft;
        }
        if (thisSum <= 0)
        {
            thisSum = 0;
            nextBeTmpLeft = true;
        }
    }
    if (maxSum >= 0)
        printf("%d %d %d", maxSum, left, right);
    else
        printf("%d %d %d", 0, first, last);
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值