PTA 1028 List Sorting (25 分) C++ sort功能实现

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题目大意:

给出n行数据和一个排序类型c,如果c=1,则按ID排列,为2,则按名字排,为3,则按成绩排。如果名字或者成绩有重复的,ID小的先输出。

AC代码:

#include<bits/stdc++.h>
using namespace std;
struct node 
{
	int id;
	char name[20];
	int score;
};
int cmp1(struct node a,struct node b)
{
	return a.id<b.id;
}
int cmp2(struct node a,struct node b)
{
	if(a.name!=b.name)
	{
		for(int i=0;i<strlen(a.name);i++)
		{
			if(a.name[i]!=b.name[i])
			return a.name[i]<b.name[i];
		}
	}
	else
	return a.id<b.id;
}
int cmp3(struct node a,struct node b)
{
	if(a.score!=b.score)
	return a.score<b.score;
	else
	return a.id<b.id;
}
int main()
{
	int n,s;
	cin>>n>>s;
	struct node stu[n];
	for(int i=0;i<n;i++)
	{
		/*cin>>stu[i].id;
		cin.sync();
		cin>>stu[i].name>>stu[i].score;*/
		scanf("%d %s %d",&stu[i].id,stu[i].name,&stu[i].score);
	}
	if(s==1)
	sort(stu,stu+n,cmp1);
	else if(s==2)
	sort(stu,stu+n,cmp2);
	else
	sort(stu,stu+n,cmp3);
	for(int i=0;i<n;i++)
	{
		printf("%06d %s %d\n",stu[i].id,stu[i].name,stu[i].score);
		//cout<<' '<<stu[i].name<<' '<<stu[i].score<<endl;
	}
	return 0;
 } 

这个题主要的问题可能就是最后一个测试点运行超时。但是只要用scanf和printf替代cin和cout就可以不超出时间。

但是这就导致不能直接使用STRING进行大小比较。而这个题比较离谱cmp不能用strcmp来达到升序排列的效果,所以就自己写了一个实现。

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值