PTA甲级 1028 List Sorting (C++)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N ( ≤ 1 0 5 ) N (≤10^5) N(105) and C C C, where N N N is the number of records and C C C is the column that you are supposed to sort the records with. Then N N N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N N N lines. That is, if C C C = 1 then the records must be sorted in increasing order according to ID’s; if C C C = 2 then the records must be sorted in non-decreasing order according to names; and if C C C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

Caution:

这道题对于会用sort的同学来说简直简单到犯规哈哈哈哈。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-15 12:48:42
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

struct Student{

    string ID;
    string name;
    int grade;

    Student(string id, string n, int g){
        ID = id;
        name = n;
        grade = g;
    }

    ~Student(){}
};

bool cmp1(Student a, Student b){
    return a.ID < b.ID;
}

bool cmp2(Student a, Student b){
    if(a.name != b.name) return a.name < b.name;
    else return a.ID < b.ID;
}

bool cmp3(Student a, Student b){
    if(a.grade != b.grade) return a.grade < b.grade;
    else return a.ID < b.ID;
}


int main(){
    int n, c;
    scanf("%d %d\n", &n, &c);

    vector<Student> students;

    for(int i = 0; i < n; ++i){
        string id, name;
        int grade;

        cin >> id >> name >> grade;

        students.emplace_back(id, name, grade);
    }

    switch(c){
        case 1: sort(students.begin(), students.end(), cmp1); break;
        case 2: sort(students.begin(), students.end(), cmp2); break;
        case 3: sort(students.begin(), students.end(), cmp3); break;
        default: break;
    }

    for(int i = 0; i < students.size(); ++i) printf("%s %s %d\n", students[i].ID.c_str(), students[i].name.c_str(), students[i].grade);

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值