1024 Palindromic Number (25 分) C++实现

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题目大意:给出一个小于十亿的正整数n和一个小于一百的正整数k,判断n与n的逆序相加之后的数是否是回文数,这个操作最多执行K次。如果是,输出相加后的数字和执行的次数;如果执行n次后依然得不到一个回文数,则输出执行第k次得到的数与k。
注意:这里有一个大坑,如果你没有判断它给出的n是否是回文数,那么它测试点2,3就会错误!
所以一定要测试一下n是否是回文(真是太坑了)
AC代码(写的比较乱大家可以去参考一下其他的大数加法):

#include<bits/stdc++.h>
using namespace std;
string a;
void add()
{
	int n=a.length();
	string temp;
	temp="0"+a;
	int bit=0;
	for(int i=a.length()-1;i>=0;i--)
	{
		temp[i+1]=a[i]-'0'+a[n-1-i]+bit;
		bit=0;
		if(temp[i+1]>'9')
		{
			temp[i+1]-=10;
			bit++;
			temp[i]++;
		}

	if(temp[0]=='0')
	{
		a=temp.substr(1);
	}
	else
	{
		a=temp;
	}
}
bool ispal(string s)
{
	int n=s.length();
	for(int i=0;i<n/2;i++)
	{
		if(s[i]!=s[n-1-i])
		return 0;
	}
	return 1;
}
int main()
{
	int k;
	cin>>a>>k;
    if(ispal(a))
	{
		cout<<a<<endl;
		cout<<0;
		return 0;
	}
	for(int i=1;i<=k;i++)
	{
		add();
		if(ispal(a))
		{
			cout<<a<<endl;
			cout<<i;
			return 0;
		}
	 } 
	cout<<a<<endl<<k;
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值