1024 Palindromic Number (25分)C/C++

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题目大意:

给定一个数字,和允许翻转后相加的次数cnt,求要多少次才能变成一个回文数字,输出那个回文数字和翻转相加了多少次,如果本身就是回文数字就输出0次,如果超过给定的次数cnt了,就输出那个不是回文的结果,并且输出给定的次数cnt。

代码:

刚开始写的int,有的数字存不下,改成用字符串存储。这个代码也放在这里,供大家参考一下。

#include<stdio.h>
int Judge(int n){
	int i = 0, j, temp = 0;
	int a[15] = {0};
	while(n > 0){
		a[i] = n % 10;
		temp = temp*10 + a[i];
		n /= 10;
		i++;
	}
	
	for(j = 0,i--; j <=i; j++,i--){
		if(a[j] != a[i])
			break;
	}
	if(j > i)//是回文数返回0
		return 0;
	else
		return temp;//不是返回交换数
}
int main(){
	long long int n;
	int k, t, i, count = 0;
	scanf("%d %d", &n, &k);
	while(t = Judge(n)){
		if(count == k){
			break;
		}
		n += t;
		count++;
	}
	printf("%d\n%d\n", n, count);
	return 0;
}

下面代码(参考柳神)时用c++写的,因为c++中的string中有反转字符串的函数reverse(),(下面链接可查看:string用法——刷题过程中的C++学习之路(3)),正好刚学习,就拿来复习一遍。

#include<iostream>
#include<string>
using namespace std;
string s;
void add(string t) {
    int len = s.length(), temp = 0;
    for(int i = 0; i < len; i++) {
        s[i] = s[i] + t[i] + temp - '0';
        temp = 0;
        if(s[i] > '9') {
            s[i] = s[i] - 10;
            temp = 1;
        }
    }
    if(temp) s += '1';
    reverse(s.begin(), s.end());
}
int main() {
    int k, i;
    scanf("%s %d", s, &k);
    for(i = 0; i <= k; i++) {
        string t = s;
        reverse(t.begin(), t.end());
        if(s == t || i == k) break;
        add(t);
    }
	printf("%s %d", s, i);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值