Problem 043——UVa 1593 - Alignment of Code

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc.

For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input 

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output 

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such thati-th word on each line starts at the same position pi.


Note for the Sample:

The `$ \sqcup$' character in the example below denotes a space character in the actual files (ASCII code 32).

Sample Input 

  start:  integer;    // begins here
stop: integer; //  ends here  
 s:  string;   
c:   char; // temp

Sample Output 

start: integer; // begins here 
stop:  integer; // ends   here 
s:     string;
c:     char;    // temp


#include<iostream>
#include<string>
#include<sstream>
#include<cstdio>
using namespace std;

string s[1008][88];
int num[1008];
int Size[88];

int input()
{
    string t;
    int i=0,j=0;
    while(getline(cin , t))
    {
        stringstream tt(t);
        while(tt >> s[i][j++])
            if(s[i][j-1].size()>Size[j-1]) Size[j-1]=s[i][j-1].size();
        num[i]=j-1;
        i++,j=0;
    }
    return i;
}

void output(int n)
{
    for(int i=0; i<n; i++)
    {
        cout << s[i][0] ;
        for(int k=0; k<Size[0]-s[i][0].size(); k++) printf(" ");
        for(int j=1; j<num[i]; j++)
        {
            printf(" ");
            cout << s[i][j];
            for(int k=0; j!=num[i]-1&&k<Size[j]-s[i][j].size(); k++) printf(" ");
        }
        printf("\n");
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("output.txt","w",stdout);
#endif // ONLINE_JUDGE
    int n=input();
    output(n);
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值