1065 A+B and C (64bit) (20 分)

在这里插入图片描述
1065 A+B and C (64bit) (20 分)
Given three integers A, B and C in (−2
63
,2
63
), you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
Thanks to Jiwen Lin for amending the test data.

#include<iostream>
using namespace std;
int main() {
    int T, count = 1;
    cin >> T;
    while (T--) {
        long long A, B, C;
        scanf("%lld %lld %lld", &A, &B, &C);//不知道为什么用cin过不了测试点2
        long long sum = A + B;
        if (A > 0 && B > 0 && sum < 0) cout << "Case #" << count++ << ": true" << endl;//如果用A+B代替sum过不了测试点1
        else if (A < 0 && B < 0 && sum >= 0) cout << "Case #" << count++ << ": false" << endl;
        else if (sum > C) cout << "Case #" << count++ << ": true" << endl;
        else cout << "Case #" << count++ << ": false" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值