STL初步(一)sort

sort 排序与检索

algorithm头文件中的sort可以对任意对象进行排序, 包括内置类型和自定义类型。前提是类型定义了“<”运算符。排序之后可以用lower_bound查找“大于或者等于x的第一个位置”。待排序/查找的元素可以放在数组里,也可以放在vector里。

sort使用数组元素默认的大小比较运算符进行排序,只有在需要按照特殊依据进行排序时才需要传入额外的比较函数。

如果希望用sort排序,这个类型需要定义“小于”运算符,或者在排序时传入一个“小于”函数。排序对象可以存在于普通数组里,也可以存在于vector中。前者用sort(a,a+n)的方式调用,后者用sore(v.begin(),v.end())的方式调用。

【例题5-1 UVA 10474 】Where is the Marble?
Raju and Meena love to play with Marbles. They have got a lot of
marbles with numbers written on them. At the beginning, Raju would
place the marbles one after another in ascending order of the numbers
written on them. Then Meena would ask Raju to find the first marble
with a certain number. She would count 1…2…3. Raju gets one point
for correct answer, and Meena gets the point if Raju fails. After some
fixed number of trials the game ends and the player with maximum
points wins. Today it’s your chance to play as Raju. Being the smart
kid, you’d be taking the favor of a computer. But don’t underestimate
Meena, she had written a program to keep track how much time you’re
taking to give all the answers. So now you have to write a program,
which will help you in your role as Raju.
Input
There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins
with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next
N lines would contain the numbers written on the N marbles. These marble numbers will not come
in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers
are greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 and Q = 0.
Output
For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend upon whether
or not the query number is written upon any of the marbles. The two different formats are described
below:
• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered
1, 2, … , N.
• ‘x not found’, if the marble with number x is not present.
Look at the output for sample input for details.
Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0
Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3
题目大意:输入含有多组测试资料,每组测试资料的第一列有2个正整数N,Q,N代表弹珠的数目,Q代表对于此组测试资料米娜问的问题的数目。接下来的N列每列有一个整数,代表这n个弹珠上的号码(未经排序)。在接下来的Q列每列有一个整数代表米娜所问的问题(球的号码)。所有输入的数字都不会大于10000,且没有负的。输出所问弹珠排序后的位置。当N = 0,Q = 0时代表输入结束。请参考样本输入。

我的代码

#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int p[10000];
    int n,q,m,k=0;
    while(cin>>n>>q)
    {
        if(n==0 && q==0) break;
        cout<<"CASE# "<<++k<<":"<<endl;//注意格式,大小写,空格,字符等
        for(int i=0;i<n;i++)
            cin>>p[i];
        sort(p,p+n);//默认从小到大排序,n为排序长度
        while(q--)
        {
            cin>>m;
            int a=lower_bound(p,p+n,m)-p;//查找大于或者等于x的第一个位置
            if(p[a]==m) cout<<m<<" found at "<<a+1<<endl;//因为数组是从0开始,而题中位置是从1开始,所以输出时+1
            else cout<<m<<" not found"<<endl;
        }
    }
    return 0;
}

参考:紫薯(《算法竞赛入门经典第2版》刘汝佳◎著)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值