STL初步(三)set

set集合

set就是数学上的集合,每个元素最多只出现一次,且其中元素已从小到大排列(唯一,已排序)。和sort一样可自定义。

例题:UVa10815 Andy’s First Dictionary
Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input
Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: “Disneyland Left.”

So they went home.

Sample Output
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

题目大意:输入一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出,单词不区分大小写。

我的代码:

#include <bits/stdc++.h>
#include<iostream>
#include<set>
#include<string>
#include<sstream>
using namespace std;

set<string> D;

int main()
{
    //freopen("E:\\rush.txt", "r", stdin);
    string s;
    while(cin>>s)
    {
        for(int i=0;i<s.length();i++)///改标点和大小写
        {
            if(isalpha(s[i]))///一种函数:判断字符ch是否为英文字母,若为英文字母,返回非0(小写字母为2,大写字母为1)。若不是字母,返回0。
                s[i]=tolower(s[i]);///改大小写,将大写改为小写
            else s[i]=' ';
        }
        stringstream ss(s);///将 string 类型的 s 复制给 ss,返回 void
        while(ss>>s)///按空格读取
            D.insert(s);
    }
    for(set<string>::iterator it=D.begin(); it!=D.end();++it)///迭代器。用法类似于指针。
        cout<<*it<<"\n";
    return 0;
}

参考:紫薯(《算法竞赛入门经典第2版》刘汝佳◎著)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值