POJ 2251 Dungeon Master

Dungeon Master

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

   
   
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

   
   
Escaped in 11 minute(s).
Trapped!

这个题简直了。。。

好吧,其实这个题大意是一个3D迷宫,然后长宽高分别是L,R,C,然后有一个起点S有一个终点E,我们的目标是从S出发到达E,计算路程距离,假设移动一次距离加1。

这个就是把迷宫推广到三维空间,用BFS还是可以很轻松做出来,只要把方向稍作修改即可。

代码如下:

/*************************************************************************
    > File Name: test_again.c
    > Author: zhanghaoran
    > Mail: 467908670@qq.com 
    > Created Time: 2015年06月01日 星期一 21时18分15秒
 ************************************************************************/

#include <stdio.h>
#include <string.h>

struct q{
	int x;
	int y;
	int z;
}q[30000];
int length[30000];
int dx[] = {1, -1, 0, 0, 0, 0};
int dy[] = {0, 0, 0, 0, -1, 1};
int dz[] = {0, 0,- 1, 1, 0, 0};
int flag[40][40][40];
char map[40][40][40];
int L, R, C, nx, ny, nz;

int bfs(){
	int rear,front;
	int xx, yy, zz;
	int i;
	memset(flag, 0, sizeof(flag));
	memset(length, 0, sizeof(length));
	
	q[0].x = nx;
	q[0].y = ny;
	q[0].z = nz;
	front = rear = 0;
	while(front <= rear){
		for(i = 0;i < 6;i ++){
			xx = q[front].x + dx[i];
			yy = q[front].y + dy[i];
			zz = q[front].z + dz[i];
			if(!flag[xx][yy][zz] && (map[xx][yy][zz] == '.' || map[xx][yy][zz] == 'E') && xx >= 0 && xx < L && yy >= 0 && yy < R && zz >= 0 && zz < C)
			{
				flag[xx][yy][zz] = 1;
				q[++rear].x = xx;
				q[rear].y = yy;
				q[rear].z = zz;
				length[rear] = length[front] + 1;
				if(map[xx][yy][zz]=='E') 
					return length[rear];
			}
		}
		front++;
	}
	return 0;
}

int main(){
	int i, j, k, len;
	while(scanf("%d%d%d\n", &L, &R, &C)){
		if(L == 0 && R == 0 && C == 0)
			 break;
		for(i = 0; i < L; i ++, getchar())
			for(j = 0;j < R; j ++, getchar())
				for(k = 0; k < C; k ++){
					scanf("%c", &map[i][j][k]);
					if(map[i][j][k] == 'S') {
						nx = i;
						ny = j;
				 		nz = k;
					}	
				}
		len=bfs();
		if(len)	
			printf("Escaped in %d minute(s).\n",len);
		else 
			printf("Trapped!\n");
	}
	return 0;
}

好吧我再贴一段代码:

/*************************************************************************
    > File Name: Dungeon_Master.c
    > Author: zhanghaoran
    > Mail: 467908670@qq.com 
    > Created Time: 2015年06月01日 星期一 18时22分17秒
 ************************************************************************/

#include <stdio.h>
#include <string.h>
struct q{
	int x;
	int y;
	int z;
}q[30000];

int length[30000];
int dx[] = {1, -1, 0, 0, 0, 0};
int dy[] = {0, 0, 0, 0, -1, 1};
int dz[] = {0, 0, -1, 1, 0, 0};
int flag[40][40][40];
char map[40][40][40];

int L, R, C, nx, ny, nz;

int bfs(){
	int rear;
	int front;
	int xx, yy, zz;
	int i;
	memset(flag, 0, sizeof(flag));
	memset(length, 0, sizeof(length));

	q[0].x = nx;
	q[0].y = ny;
	q[0].z = nz;

	front = rear = 0;
	while(front <= rear){
		for(i = 0; i < 6; i ++){
			xx = q[front].x + dx[i];
			yy = q[front].y + dy[i];
			zz = q[front].z + dz[i];
			if(!flag[xx][yy][zz] && (map[xx][yy][zz] == '.' || map[xx][yy][zz] == 'E') && xx >= 0 && xx < L && yy < R && yy >= 0 && zz >= 0 && zz < C){
				flag[xx][yy][zz] = 1;
				q[++rear].x = xx;
				q[rear].y = yy;
				q[rear].z = zz;
				length[rear] = length[front] + 1;
				if(map[xx][yy][zz] == 'E')
					return length[rear];
			}
		}
		front ++;
	}
	return 0;
}

int main(void){
	int i, j, k, len;
	while(scanf("%d%d%d\n" ,&L, &R, &C)){
		if(L == 0 && R == 0 && C == 0)
			break;
		
		for(i = 0; i < L; i ++, getchar())
			for(j = 0; j < R; j ++, getchar())
				for(k = 0; k < C; k ++){
					scanf("%c", &map[i][j][k]);
					if(map[i][j][k] == 'S'){
						nx = i;
						ny = j;
						nz = k;
					}
				}
		len = bfs();
		if(len) 
			printf("Escaped in %d minute(s).\n", len);
		else printf("Trapped\n");
	}
	return 0;
}


这两个代码是不是看起来完全一样?我也是这么认为的。。。然而我并不知道为什么第一个提交的时候就是AC,第二个就是WA,第一个是因为我第二个找不到错的地方重新写了一遍,这个问题有待解决。这就是为什么说这个题简直了。。

POJ2251是一个经典的题目,也被称为"水仙花的谜题"。该题目要求在一个三维的迷宫中找到从起点到终点的最短路径。 在这个题目中,迷宫由一个3D的数组表示,每个位置上的值代表了该位置的状态。其中,0表示可以通过的路径,1表示墙壁,2表示起点,3表示终点。你需要编写一个程序来找到从起点到终点的最短路径,并输出路径的长度。 解决这个问题的一种常见方法是使用广度优先搜索(BFS)算法。BFS算法可以从起点开始,逐层遍历迷宫中的位置,直到找到终点或者遍历完所有可达位置。在遍历过程中,你需要记录每个位置的距离和路径信息,以便找到最短路径。 以下是解决该问题的大致思路: 1. 定义一个队列,将起点加入队列,并标记起点已访问。 2. 使用循环来遍历队列中的元素,直到队列为空。 3. 在循环中,取出队列中的元素,并获取其相邻可达位置。 4. 对于每个相邻位置,判断是否为终点,如果是则输出最短路径长度并结束程序。 5. 如果不是终点,则判断该位置是否为可通过的路径,并且未被访问过。如果满足条件,则将该位置加入队列,并更新距离和路径信息。 6. 重复步骤2-5,直到找到终点或者遍历完所有可达位置。 这只是一个简单的介绍,实际解决该问题还需要考虑一些细节,比如如何表示迷宫、如何判断位置的合法性等。你可以在编写代码时参考相关的算法和数据结构知识。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值