POJ 3278 Catch That Cow

Catch That Cow

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?



Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4


这个题的算法思想很容易看出就是BFS,就是一个很简单的BFS的原理的应用,需要注意的是特殊情况,也就是两者位置相同时,那个时候需要提前判断并返回0值,代码如下。


/*************************************************************************
    > File Name: Catch_That_Cow.c
    > Author: zhanghaoran
    > Mail: 467908670@qq.com
    > Created Time: 2015年06月04日 星期四 14时21分43秒
 ************************************************************************/

#include <stdio.h>
#include <string.h>

int q[1000010];
int step[1000010];      //利用一个数组既可以判断是否经过这个点,同时也可以给出到达这个点所需的距离。
int n, k;


int bfs(){
	int rear = 0, front = 0;
	int nowpos;
	if(n == k)
	return 0;
	q[rear ++] = n;
	while(front <= rear){
		nowpos = q[front ++];
		if(nowpos - 1 == k || nowpos + 1 == k || nowpos * 2 == k)
			return step[nowpos] + 1;
		if(nowpos - 1 > 0 && nowpos - 1 < 1000010 && !step[nowpos - 1]){
			step[nowpos - 1] = step[nowpos] + 1;
			q[rear ++] = nowpos - 1;
		}
		if(nowpos + 1 < 1000010 && !step[nowpos + 1]){
			step[nowpos + 1] = step[nowpos] + 1;
			q[rear ++] = nowpos + 1;
		}
		if(nowpos * 2 < 1000010 && !step[nowpos * 2]){
			step[nowpos * 2] = step[nowpos] + 1;
			q[rear ++] = nowpos * 2;
		}
	}
}

int main(void){
	while(scanf("%d%d",&n,&k) != EOF){
		memset(step, 0, sizeof(step));
		printf("%d\n", bfs());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值