HDU 1029 Ignatius and the Princess IV

B - Ignatius and the Princess IV
Time Limit:1000MS    Memory Limit:32767KB    64bit IO Format:%I64d & %I64u

Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output

For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input

    
    
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output

    
    
3 5 1
 

一道很水的题,不过思想还是值的借鉴的。设置计数器1个,设置第一个为参考,每出现一个与当前计数器代表数字相同的数字的时候计数器加1,否则减1,如果计数器变成0,就更换计数器代表数字。最后输出最后的代表数字即可

代码如下:

/*************************************************************************
	> File Name: Ignatius_and_the_Princess_IV.cpp
	> Author: Zhanghaoran
	> Mail: chilumanxi@xiyoulinux.org
	> Created Time: Thu 22 Oct 2015 10:37:44 PM CST
 ************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;

int n;
int main(void){
    while(~scanf("%d", &n)){
        int x, y, res = 1;;
        for(int i = 0; i < n; i ++){
            scanf("%d", &x);
            if(i == 0){
                y = x;
                continue;
            }
            if(res > 0){
                if(x == y)
                    res ++;
                else res --;
            }
            else{
                res = 1;
                y = x;
            }
        }
        printf("%d\n", y);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值