HDU 4300 Clairewd’s message

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4666    Accepted Submission(s): 1777

Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.

Input

The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.

Hint

Range of test data:
T<= 100 ;
n<= 100000;

Output
For each test case, output one line contains the shorest possible complete text.
Sample Input
2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde
Sample Output
abcdabcd
qwertabcde
题意是每组数据给定两个字符串,第一个是26个字母的字符串,代表着密文的转化规则,即密文的str[i]对应的是i + 'a',换句话说,比方说第二组数据,则密文q对应明文a,w对应b,以此类推。
第二个字符串是由一个密文串全部和明文串的一部分或全部组合而来的,比如第一组数据就是由密文串abcd和明文ab组成,而第二组数据是由密文qwert和明文abcde组成。
最后输出的是完整的密文+完整的明文
这个题我采取的方法是将给定的第二个字符串按照转化规则全部进行转化,然后以此为模板串x,以原串为主串y,通过扩展KMP算法,计算y[i...n-1]与x[0...n-1]的最长公共前缀(两者长队n必定相同)当满足i+extend[i]大于等于n并且满足i大于extend[i],这么做的原因是必须保证密文串长度大于等于明文串。
找到这个i以后,循环两遍输出结果即可
代码如下:
/*************************************************************************
	> File Name: Clairewds_message.cpp
	> Author: Zhanghaoran
	> Mail: chilumanxi@xiyoulinux.org
	> Created Time: 2016年02月18日 星期四 21时10分47秒
 ************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <string>
using namespace std;

int ss[26];
string str;
string temp;
char srt[100010];
int T;

int nexti[100010];
int N;

void pre_EKMP(){
    nexti[0] = N;
    int j = 0;
    while(j + 1 < N && srt[j] == srt[j + 1])
        j ++;
    nexti[1] = j;
    int k = 1;
    for(int i = 2; i < N; i ++){
        int p = nexti[k] + k - 1;
        int L = nexti[i - k];
        if(i + L < p + 1)
            nexti[i] = L;
        else{
            j = max(0, p - i + 1);
            while(i + j < N && srt[i + j] == srt[j])
                j ++;
            nexti[i] = j;
            k = i;
        }
    }
}

int extend[100010];

void EKMP(){
    pre_EKMP();
    int j = 0;
    while(j < N && j < N && str[j] == srt[j])
        j ++;
    extend[0] = j;
    int k = 0;
    for(int i = 1; i < N ; i ++){
        int p = extend[k] + k - 1;
        int L = nexti[i - k];
        if(i + L < p + 1)
            extend[i] = L;
        else{
            j = max(0, p - i + 1);
            while(i + j < N && j < N && str[i + j] == srt[j])
            j ++;
            extend[i] = j;
            k = i;
        }
    }
}
int main(void){
    cin >> T;
    while(T --){
        cin >> temp;
        for(int i = 0; i < temp.size(); i ++){
            ss[temp[i] - 'a'] = temp[i] - 'a' - i;
        }
        cin >> str;
        memset(srt, 0, sizeof(srt));
        for(int i = 0; i < str.size(); i ++){
            srt[i] = str[i] - ss[str[i] - 'a'];
        }   
        N = str.size();
        EKMP();
        int k;
        for(k= 0; k< N; k++)
        {
            if(k + extend[k] >= N && k >= extend[k])
                break;
        }
        for(int i = 0; i < k; i ++)
            printf("%c",str[i]);
        for(int i = 0; i < k; i ++)
            printf("%c",srt[i]);
        puts("");
    }
}

 

查看原文:http://chilumanxi.org/2016/02/18/hdu-4300-clairewds-message/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C语言是一种广泛使用的编程语言,它具有高效、灵活、可移植性强等特点,被广泛应用于操作系统、嵌入式系统、数据库、编译器等领域的开发。C语言的基本语法包括变量、数据类型、运算符、控制结构(如if语句、循环语句等)、函数、指针等。在编写C程序时,需要注意变量的声明和定义、指针的使用、内存的分配与释放等问题。C语言中常用的数据结构包括: 1. 数组:一种存储同类型数据的结构,可以进行索引访问和修改。 2. 链表:一种存储不同类型数据的结构,每个节点包含数据和指向下一个节点的指针。 3. 栈:一种后进先出(LIFO)的数据结构,可以通过压入(push)和弹出(pop)操作进行数据的存储和取出。 4. 队列:一种先进先出(FIFO)的数据结构,可以通过入队(enqueue)和出队(dequeue)操作进行数据的存储和取出。 5. 树:一种存储具有父子关系的数据结构,可以通过中序遍历、前序遍历和后序遍历等方式进行数据的访问和修改。 6. 图:一种存储具有节点和边关系的数据结构,可以通过广度优先搜索、深度优先搜索等方式进行数据的访问和修改。 这些数据结构在C语言中都有相应的实现方式,可以应用于各种不同的场景。C语言中的各种数据结构都有其优缺点,下面列举一些常见的数据结构的优缺点: 数组: 优点:访问和修改元素的速度非常快,适用于需要频繁读取和修改数据的场合。 缺点:数组的长度是固定的,不适合存储大小不固定的动态数据,另外数组在内存中是连续分配的,当数组较大时可能会导致内存碎片化。 链表: 优点:可以方便地插入和删除元素,适用于需要频繁插入和删除数据的场合。 缺点:访问和修改元素的速度相对较慢,因为需要遍历链表找到指定的节点。 栈: 优点:后进先出(LIFO)的特性使得栈在处理递归和括号匹配等问题时非常方便。 缺点:栈的空间有限,当数据量较大时可能会导致栈溢出。 队列: 优点:先进先出(FIFO)的特性使得

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值