HDU 2680:Choose the best route(Dijkstra算法)

Choose the best route

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 68   Accepted Submission(s) : 29
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1



本题采用Dijkstra算法
把不存在的0设置为起始点
将起点位置和0的距离代价记为0
用这种方式,将原先O(n^3)的最坏情况复杂度
变成了O((n+1)^2),若不采取这种方式将会超时。
另外,该题采用的是有向图,需要注意。
下面是AC代码:

#include<iostream>
#include<cstdio>
#include<string.h>


using namespace std;
int map[1005][1005];
int dist[1005];
int visited[1005];
int en,m,n,st;
const int inf=9999999999;


void Dijkstra()
{
    int min,pos;
   memset(visited,0,sizeof(visited));
    for(int i=0;i<=n;i++)
        dist[i]=map[0][i];
    visited[0]=1;
    for(int i=0;i<=n;i++)
    {
        min=inf;
        for(int j=0;j<=n;j++)
            {
                if(!visited[j]&&dist[j]<min)
                {
                    min=dist[j];
                    pos=j;
                }
            }
            if(min==inf) break;
            visited[pos]=1;
            for(int j=0;j<=n;j++)
            {
                if(!visited[j]&&dist[pos]+map[pos][j]<dist[j])
                    dist[j]=map[pos][j]+dist[pos];
            }
    }
}


int main()
{
    int p,q,c,w,g;
    while(~scanf("%d%d%d",&n,&m,&en))
    {
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
        {
            map[i][j]=inf;
            if(i==j) map[i][j]=0;
        }
        while(m--)
        {
            scanf("%d%d%d",&p,&q,&c);
            if(map[p][q]>c)
            {
                map[p][q]=c;
            }
        }
        scanf("%d",&w);
        g=inf;
        for(int i=1;i<=w;i++)
        {
            cin>>st;
            map[0][st]=0;
        }
        Dijkstra();
        if(dist[en]!=inf) cout<<dist[en]<<endl;
        else cout<<"-1"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值