POJ 1835 宇航员

宇航员
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 5765 Accepted: 2517

Description

问题描述: 
  宇航员在太空中迷失了方向,在他的起始位置现在建立一个虚拟xyz坐标系,称为绝对坐标系,宇航员正面的方向为x轴正方向,头顶方向为z轴正方向,则宇航员的初始状态如下图所示: 

现对六个方向分别标号,x,y,z正方向分别为0,1,2,负方向分别为3,4,5;称它们为绝对方向。宇航员在宇宙中只沿着与绝对坐标系xyz轴平行的方向行走,但是他不知道自己当前绝对坐标和自己面向的绝对方向。 

任务描述: 
  请根据宇航员对自己在相对方向上移动的描述确定宇航员最终的绝对坐标和面向的绝对方向。对在相对方向上移动的描述及意义如下: 
forward x  向前走x米。 
back x 先转向后,再走x米。 
left x 先转向左,再走x米。 
right x 先转向右,再走x米。 
up x 先面向上,再走x米。 
down x 先面向下,再走x米。 
其中向上和向下如下图所示: 

Input

第一行一个正整数m,表示测试数据的组数。每组测试数据第一行是一个正整数n(1<=n<=10000)表示宇航员行走的次数,下面n行每行输入一次相对行走,格式如上所述,其中( 1 <= x <= 10000 为正整数)。

Output

对于每组输入数据输出一行,x y z p, 中间用空格隔开,x y z是宇航员的位置的绝对坐标,p是宇航员面向的绝对方向编号(0<=p <=5)。

Sample Input

1
6
left 10
right 11
up 12
down 13
forward 14
back 15

Sample Output

23 -10 12 3




代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<set>
#include<stack>
#include<queue>
#include<string.h>
#include<algorithm>

using namespace std;
typedef long long ll;

const int inf=99999;
const int mod=1000000007;

int n,t,cnt,flag;
ll m;
int use[1001];
char s[10];
  int main()
  { 
      int t, n;
  int x, y, z, face, left, ver, temp, d;
  scanf("%d", &t);
  while (t--)
    {
        scanf("%d", &n);
        x = y = z = 0;
        face = 0,
        left = 4,
        ver = 2;
     while (n--)
        {
            scanf("%s %d", s, &d);
     if (s[0] == 'b')
        face = (face + 3) % 6, left = (left + 3) % 6;
        else if (s[0] == 'l')
        temp = face, face = left, left = (temp + 3) % 6;
        else if (s[0] == 'r') temp = left, left = face, face = (temp + 3) % 6;
        else if (s[0] == 'u') temp = face, face = ver, ver = (temp + 3) % 6;
        else if (s[0] == 'd') temp = ver, ver = face, face = (temp + 3) % 6;
      if (face == 0) x += d;
        else if (face == 1) y += d;
        else if (face == 2) z += d;
        else if (face == 3) x -= d;
        else if (face == 4) y -= d;
        else z -= d;
        }
       printf("%d %d %d %d\n", x, y, z, face); }
       return 0;
       }



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值