HDU 3652 B-number(数位dp)

B-number

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output

Print each answer in a single line.

Sample Input

13
100
200
1000

Sample Output

1
1
2
2

Author

wqb0039

Source

2010 Asia Regional Chengdu Site —— Online Contest


这道题的意思是给出一个数,问从1到这个数之间有多少数既有子串13,又能被13整除。

简单的数位dp题

#include <iostream>
#include<string>
#include<cstring>
#include<set>
#include<cstdio>
using namespace std;
typedef long long ll;

ll dp[25][15][3];
ll a[25];

ll dfs(int pos,bool is,int state2,int state,bool limit)
{
    if(pos==-1&&state==1&&state2==0) return 1;
    else if(pos==-1) return 0;
    if(!limit&&dp[pos][state2][state]!=-1) return dp[pos][state2][state];
    int up=limit?a[pos]:9;
    ll temp=0;
    for(int i=0;i<=up;i++)
    {
        if((is&&i==3)||state==1)
        temp+=dfs(pos-1,i==1,(state2*10+i)%13,1,limit&&a[pos]==i);
        else if(i==1) temp+=dfs(pos-1,i==1,(state2*10+i)%13,2,limit&&a[pos]==i);
        else temp+=dfs(pos-1,i==1,(state2*10+i)%13,0,limit&&a[pos]==i);
    }
    if(!limit) dp[pos][state2][state]=temp;
    return temp;
}

ll solve(ll x)
{
    memset(dp,-1,sizeof(dp));
    int pos=0;
    while(x)
    {

        a[pos++]=x%10;
        x/=10;
    }
    return dfs(pos-1,0,0,0,true);
}

int main()
{
    ll x;
    while(~scanf("%lld",&x))
    {
        cout<<solve(x)<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值