HDU 1695 GCD(容斥定理)

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11186    Accepted Submission(s): 4242


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 



题意:给两个集合,找出这两个集合中gcd为某个值的对数

思路:

b和d分别除以k之后的区间里面,只需要求gcd(x, y) = 1就可以了,这样子求出的数的对数不变。

这道题目还要求1-3 和 3-1 这种情况算成一种,因此只需要限制x<y就可以了


只需要枚举x,然后确定另一个区间里面有多少个y就可以了。因此问题转化成为区间(1, d)里面与x互素的数的个数

先求出x的所有质因数,因此(1,d)区间里面是x的质因数倍数的数都不会与x互素,因此,只需要求出这些数的个数,减掉就可以了。

如果w是x的素因子,则(1,d)中是w倍数的数共有d/w个。


#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long ll;

const int MAXN=1e5+5;
int prime[MAXN][10];
int cnt[MAXN];

void sieve(int n)
{
    for(int i=2;i<=n;i++)
    {
        if(cnt[i]!=0) continue;
        prime[i][0]=i;
        cnt[i]=1;
        for(int j=2;j*i<=n;j++)
            prime[i*j][cnt[i*j]++]=i;
    }
}

ll solve(int m,int n,int pos)
{
    ll res=0;
    for(int i=1;i<(1<<m);i++)
    {
        int num=0;
        for(int j=i;j!=0;j>>=1) num+=j&1;
        int lcm=1;
        for(int j=0;j<m;j++)
        {
            if(i>>j&1)
            {
                lcm=lcm/__gcd(lcm,prime[pos][j])*prime[pos][j];
                if(lcm>n) break;
            }
        }
        if(num%2==0) res-=(ll)(n/lcm);
        else res+=(ll)(n/lcm);
    }
    return res;
}

int main()
{
    sieve(100005);
    int t;
    scanf("%d",&t);
    int casi=1;
    while(t--)
    {
        int a,b,c,d,e;
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&e);
        if(e==0)
        {
            printf("Case %d: %lld\n",casi++,0);
            continue;
        }
        b/=e;d/=e;
        if(b>d) swap(b,d);
        ll ans=0;
        for(int i=a;i<=b;i++)
        {
            ans+=(ll)d-(solve(cnt[i],d,i))-((ll)(i-1)-(solve(cnt[i],i-1,i)));
        }
        printf("Case %d: %lld\n",casi++,ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值