HDU 4704 Sum(费马小定理,组合数学,快速幂)

Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2738    Accepted Submission(s): 1140


Problem Description
 

Sample Input
  
  
2
 

Sample Output
  
  
2
Hint
1. For N = 2, S(1) = S(2) = 1. 2. The input file consists of multiple test cases.
 



思想:根据组合数学,总是为2^n,根据费马小定理缩小n的范围,再矩阵快速幂即可求出答案。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
#define ms(a,b)memset(a,b,sizeof(a))
#define eps 1e-10
#define inf 1e8

typedef long long ll;
typedef vector<ll> vec;
typedef vector<vec> mat;

const ll M=1000000007;

ll mod_pow(ll x,ll n)
{
    ll ans=1;
    while(n>0)
    {
        if(n&1) ans=(ans*x)%M;
        x=x*x%M;
        n>>=1;
    }
    return ans;
}


int main()
{
    ll a,b,n;
    string s;
    ll ans=0;
    while(cin>>s)
    {
        ans=0;
       for(int i=0;i<s.length();i++)
       {
           ans=ans*10+s[i]-'0';
           ans%=(M-1);
       }
       ans--;
        cout<<mod_pow(2,ans)<<endl;
    }
    return 0;
}

JAVA:(TLE)

import java.math.BigInteger;
import java.util.Scanner;


public class Main {
	public static void main(String[] args) {
		BigInteger n;
		Scanner cin=new Scanner(System.in);
		while(cin.hasNextBigInteger()){
		n=cin.nextBigInteger();
		n=n.subtract(BigInteger.ONE);
		n=n.mod(new BigInteger("1000000006"));
		System.out.println(mod_pow(new BigInteger("2"),n,new BigInteger("1000000007")));
		}
	}
	public static BigInteger mod_pow(BigInteger x,BigInteger n,BigInteger mod)
	{
		BigInteger res=new BigInteger("1");
		while(n.compareTo(BigInteger.ZERO)>0)
		{
			if(n.mod(new BigInteger("2")).compareTo(BigInteger.ONE)==0)
			{
				res=res.multiply(x);
				res=res.mod(mod);
			}
			x=x.multiply(x);
			x=x.mod(mod);
			n=n.divide(new BigInteger("2"));
		}
		return res;
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值