[Codeforces Round #316] Replacement

Problem Description

Daniel has a string s, consisting of lowercase English letters and period signs (characters ‘.’). Let’s define the operation of replacement as the following sequence of steps: find a substring “..” (two consecutive periods) in string s, of all occurrences of the substring let’s choose the first one, and replace this substring with string “.”. In other words, during the replacement operation, the first two consecutive periods are replaced by one. If string s contains no two consecutive periods, then nothing happens.

Let’s define f(s) as the minimum number of operations of replacement to perform, so that the string does not have any two consecutive periods left.

You need to process m queries, the i-th results in that the character at position xi (1 ≤ xi ≤ n) of string s is assigned value ci. After each operation you have to calculate and output the value of f(s).

Help Daniel to process all queries.

Input

The first line contains two integers n and m (1 ≤ n, m ≤ 300 000) the length of the string and the number of queries.

The second line contains string s, consisting of n lowercase English letters and period signs.

The following m lines contain the descriptions of queries. The i-th line contains integer xi and ci (1 ≤ xi ≤ n, ci — a lowercas English letter or a period sign), describing the query of assigning symbol ci to position xi.

Output

Print m numbers, one per line, the i-th of these numbers must be equal to the value of f(s) after performing the i-th assignment.

Sample Input

10 3
.b..bz….
1 h
3 c
9 f

Sample Output

4
3
1

Sample Input

4 4
.cc.
2 .
3 .
2 a
1 a

Sample Output

1
3
1
1

Note

Note to the first sample test (replaced periods are enclosed in square brackets).

The original string is “.b..bz….”.

after the first query f(hb..bz….) = 4 (“hb[..]bz….”  →  “hb.bz[..]..”  →  “hb.bz[..].”  →  “hb.bz[..]”  →  “hb.bz.”)
after the second query f(hbс.bz….) = 3 (“hbс.bz[..]..”  →  “hbс.bz[..].”  →  “hbс.bz[..]”  →  “hbс.bz.”)
after the third query f(hbс.bz..f.) = 1 (“hbс.bz[..]f.”  →  “hbс.bz.f.”)
Note to the second sample test.

The original string is “.cc.”.

after the first query: f(..c.) = 1 (“[..]c.”  →  “.c.”)
after the second query: f(….) = 3 (“[..]..”  →  “[..].”  →  “[..]”  →  “.”)
after the third query: f(.a..) = 1 (“.a[..]”  →  “.a.”)
after the fourth query: f(aa..) = 1 (“aa[..]”  →  “aa.”)

My Problem Report

一道简单的C题,不用想太复杂,模拟即可。当我们将字母修改成句点时,如果它前面是句点,答案++,如果它后面是句点,答案++。将句点修改为字母时操作相似。

My Source Code

//  Created by Chlerry in 2015.
//  Copyright (c) 2015 Chlerry. All rights reserved.
//

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <cstring>
#include <climits>
#include <string>
#include <vector>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <unordered_map>
using namespace std;
#define Size 100000
#define ll long long
#define mk make_pair
#define pb push_back
#define mem(array, x) memset(array,x,sizeof(array))
typedef pair<int,int> P;

int main()
{
    int n,m;string a;
while(cin>>n>>m)
{
    cin>>a;int ans=0;
    for(int i=1;i<a.size();i++)
        if(a[i]=='.' && a[i-1]=='.')
            ans++;
    int loc;string c;
    for(int i=0;i<m;i++)
    {
        cin>>loc>>c;loc--;
        if(c[0]!='.' && a[loc]!='.')
            cout<<ans<<endl;
        else if(c[0]=='.' && a[loc]=='.')
            cout<<ans<<endl;
        else if(c[0]=='.')
        {
            if(loc>0 && a[loc-1]=='.')
                ans++;
            if(loc<a.size()-1 && a[loc+1]=='.')
                ans++;
            a[loc]='.';
            cout<<ans<<endl;
        }
        else
        {
            if(loc>0 && a[loc-1]=='.')
                ans--;
            if(loc<a.size()-1 && a[loc+1]=='.')
                ans--;
            a[loc]=c[0];
            cout<<ans<<endl;
        }
    }
}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值