codeforce 570C 字符串

Replacement
TimeLimit:2000MS MemoryLimit:256MB
64-bit integer IO format:%I64d
Problem Description
Daniel has a string s, consisting of lowercase English letters and period signs (characters ‘.’). Let’s define the operation of replacement as the following sequence of steps: find a substring “…” (two consecutive periods) in string s, of all occurrences of the substring let’s choose the first one, and replace this substring with string “.”. In other words, during the replacement operation, the first two consecutive periods are replaced by one. If string s contains no two consecutive periods, then nothing happens.

Let’s define f(s) as the minimum number of operations of replacement to perform, so that the string does not have any two consecutive periods left.

You need to process m queries, the i-th results in that the character at position xi (1 ≤ xi ≤ n) of string s is assigned value ci. After each operation you have to calculate and output the value of f(s).

Help Daniel to process all queries.

Input
The first line contains two integers n and m (1 ≤ n, m ≤ 300 000) the length of the string and the number of queries.

The second line contains string s, consisting of n lowercase English letters and period signs.

The following m lines contain the descriptions of queries. The i-th line contains integer xi and ci (1 ≤ xi ≤ n, ci — a lowercas English letter or a period sign), describing the query of assigning symbol ci to position xi.

Output
Print m numbers, one per line, the i-th of these numbers must be equal to the value of f(s) after performing the i-th assignment.

SampleInput 1
10 3
.b…bz…
1 h
3 c
9 f
SampleOutput 1
4
3
1
SampleInput 2
4 4
.cc.
2 .
3 .
2 a
1 a
SampleOutput 2
1
3
1
1

Note

Note to the first sample test (replaced periods are enclosed in square brackets).

The original string is “.b…bz…”.

after the first query f(hb…bz…) = 4 (“hb[…]bz…”  →  “hb.bz[…]…”  →  “hb.bz[…].”  →  “hb.bz[…]”  →  “hb.bz.”)

after the second query f(hbс.bz…) = 3 (“hbс.bz[…]…”  →  “hbс.bz[…].”  →  “hbс.bz[…]”  →  “hbс.bz.”)

after the third query f(hbс.bz…f.) = 1 (“hbс.bz[…]f.”  →  “hbс.bz.f.”)

Note to the second sample test.

The original string is “.cc.”.

after the first query: f(…c.) = 1 ("[…]c."  →  “.c.”)

after the second query: f(…) = 3 ("[…]…"  →  “[…].”  →  “[…]”  →  “.”)

after the third query: f(.a…) = 1 (".a[…]"  →  “.a.”)

after the fourth query: f(aa…) = 1 (“aa[…]”  →  “aa.”)

题意:给出一个长度为n的字符串和m次修改,询问每次修改后连续两个点的个数
思路:一开始想的暴力 搓完之后就奖励了我一发TLE 一看数据范围 就知道这题没那么简单了 - -,然后经过观察可以发现,只有更改了 点 所在位置的元素 (将点修改成其他元素或将其他元素修改成点才会对答案有影响)所以我们先跑一遍记录答案,每次修改的时候判断他是否对答案造成影响然后更新答案就行了这样就可以在O(1)的时间内更新答案

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>

using namespace std;

int main()
{
    int n,m;
    ios::sync_with_stdio(false);

    while(cin >> n >> m)
    {
        string s;

        cin >> s;
        int res=0;

        for(int i=0;i<n;i++)
        {
            if(s[i]==s[i+1]&&s[i]=='.')///记录初始答案
                  res++;
        }

        while(m--)
        {
            int x;
            char c;

            cin >> x >> c;

            if(s[x-1]=='.'&&s[x]=='.')res--;///如果修改的元素是点就先将答案减去
            if(s[x-1]=='.'&&s[x-2]=='.')res--;
            s[x-1]=c;///更新
            if(s[x-1]=='.'&&s[x]=='.')res++;///更新后该位置还是点就将答案还原
            if(s[x-1]=='.'&&s[x-2]=='.')res++;

            cout << res << endl;
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值