Problem Description
Limak is an old brown bear. He often plays poker with his friends. Today they went to a casino. There are n players (including Limak himself) and right now all of them have bids on the table. i-th of them has bid with size ai dollars.
Each player can double his bid any number of times and triple his bid any number of times. The casino has a great jackpot for making all bids equal. Is it possible that Limak and his friends will win a jackpot?
Input
First line of input contains an integer n (2 ≤ n ≤ 105), the number of players.
The second line contains n integer numbers a1, a2, …, an (1 ≤ ai ≤ 109) — the bids of players.
Output
Print “Yes” (without the quotes) if players can make their bids become equal, or “No” otherwise.
Sample Input
4
75 150 75 50
Sample Output
Yes
Input
3
100 150 250
Output
No
Note
In the first sample test first and third players should double their bids twice, second player should double his bid once and fourth player should both double and triple his bid.
It can be shown that in the second sample test there is no way to make all bids equal.
My Problem Report
这道题只要不想复杂了就行。一开始可能很多人想到的都是求最大公约数,其实根本没有必要,采用逆向思维,把每个数的因子2、3全部除去,判断最终是否相等即可。
My Source Code
// Created by Chlerry in 2015.
// Copyright (c) 2015 Chlerry. All rights reserved.
//
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <cstring>
#include <climits>
#include <string>
#include <vector>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define Size 100000
#define ll long long
#define mk make_pair
#define pb push_back
#define mem(array, x) memset(array,x,sizeof(array))
typedef pair<int,int> P;
ll a[Size];
int main()
{
int n;cin>>n;
for(int i=0;i<n;i++)
{
cin>>a[i];
while(a[i]%2==0)
a[i]/=2;
while(a[i]%3==0)
a[i]/=3;
}
for(int i=1;i<n;i++)
if(a[0]==a[i])
continue;
else
{
cout<<"No\n";
return 0;
}
cout<<"Yes\n";
return 0;
}