迷宫问题

Description
定义一个二维数组:
int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。最短路径保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input Copy
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output Copy
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

解题思路
使用两个双向队列存储走过的点,一个队列存储正在走的点,一个队列存储最优解的点。

AC代码

#include<bits/stdc++.h>
using namespace std;
#define ios ios::sync_with_stdio(false); cin.tie(NULL);
//const int N = 110;
int n;
int m;
int mp[5][5];
int ans;//走的步数
int nice;//最优解的步数
int fx[]= {0,1,0,-1};
int fy[]= {-1,0,1,0};
struct node
{
    int a;
    int b;
}str,cnt[25];
int k;
deque<node>p;//暂存每一次的路径
deque<node>q;//存储最优路径
bool vis[5][5];
bool check(int x,int y)
{
    if(x>=0&&x<5&&y>=0&&y<5&&mp[x][y]==0&&!vis[x][y])
    {
        return true;
    }
    return false;
}

void dfs(int x,int y,int ans)
{
    if(ans>nice) return ;
    if(x==4&&y==4)
    {
        if(ans<nice)
        {
            nice = ans;
            while(!q.empty())
            {
                q.pop_back();
            }
            k=0;
            while(!p.empty())
            {
                q.push_back(p.front());
                cnt[k] = p.front();
                p.pop_front();
                k++;
            }
            for(int i=0; i<k; i++)
            {
                p.push_back(cnt[i]);
            }
        }
        return ;
    }

    for(int i=0; i<4; i++)
    {
        str.a = x+fx[i];
        str.b = y+fy[i];
        if(check(str.a,str.b))
        {
            p.push_back(str);
            vis[x][y] = true;
            dfs(str.a,str.b,ans+1);
            vis[x][y] = false;
            p.pop_back();

        }
    }
    return ;
}


int main()
{
    for(int i=0; i<5; i++)
    {
        for(int j=0; j<5; j++)
        {
            cin>>mp[i][j];
        }
    }
    nice=100;
    dfs(0,0,0);
    cout<<'('<<0<<", "<<0<<')'<<endl;
    while(!q.empty())
    {
        cout<<'('<<q.front().a<<", "<<q.front().b<<')'<<endl;
        q.pop_front();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值