1060 Are They Equal (25)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*10^5^ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^100^, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d~1~...d~N~*10\^k" (d~1~>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3
#include<cstdio>
#include<iostream>
#include<fstream>
#include<string>
using namespace std;
int n;
string deal(string s, int& e){
	int k=0;
	while(s.length()>0 && s[0]=='0'){				//去除前导0 
		s.erase(s.begin());
	}
	if(s[0]=='.'){									//去除后如果第一位是小数点 
		s.erase(s.begin());
		while(s.length() > 0 && s[0]=='0'){			//去除小数点后判断有几个0,每有一个则指数-1 
			s.erase(s.begin());
			e--;
		}
	} else{											//如果第一位不是0那么判断小数点前有几位数字 
		while(k<s.length() && s[k]!='.'){
			k++;
			e++;
		}
		if(k<s.length()) s.erase(s.begin()+k);		//离开循环后k小于字符串长度说明遇到了小数点 去除 
	}
	if(s.length() == 0) e=0;						//如果前导0去除后字符串长度为0 则指数为0 
	int num=0;
	k=0;
	string res;										//记录科学计数法主体部分 
	while(num<n){									//精度 
		if(k<s.length()) res+=s[k++];				//还有数字就加入末尾 
		else res+='0';								//没有了就补0 
		num++;
	}
	return res;
}
int main(){
	string s1, s2, s3, s4;
	cin>>n>>s1>>s2;
	int e1=0, e2=0;
	s3=deal(s1, e1);
	s4=deal(s2, e2);
	if(s3==s4 && e1==e2){
		cout<<"YES 0."<<s3<<"*10^"<<e1<<endl;
	} else{
		cout<<"NO 0."<<s3<<"*10^"<<e1<<" 0."<<s4<<"*10^"<<e2<<endl;
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Here is the function template for isEqualTo: ``` template<typename T> bool isEqualTo(const T& a, const T& b) { return a == b; } ``` Here is an example program that uses isEqualTo with built-in types: ``` #include <iostream> int main() { std::cout << std::boolalpha; std::cout << isEqualTo(5, 5) << std::endl; std::cout << isEqualTo(5, 7) << std::endl; std::cout << isEqualTo('a', 'a') << std::endl; std::cout << isEqualTo('a', 'b') << std::endl; std::cout << isEqualTo(true, true) << std::endl; std::cout << isEqualTo(true, false) << std::endl; std::cout << isEqualTo(3.14, 3.14) << std::endl; std::cout << isEqualTo(3.14, 2.71) << std::endl; return 0; } ``` When we attempt to run this program with the user-defined class type Complex, we get a compilation error because the compiler doesn't know how to compare two Complex objects. To fix this, we can overload the equality operator in the Complex class: ``` class Complex { public: Complex(double real, double imag) : m_real(real), m_imag(imag) {} double real() const { return m_real; } double imag() const { return m_imag; } private: double m_real; double m_imag; }; bool operator==(const Complex& lhs, const Complex& rhs) { return lhs.real() == rhs.real() && lhs.imag() == rhs.imag(); } ``` Now when we attempt to run the program with Complex objects, it works as expected: ``` #include <iostream> class Complex { public: Complex(double real, double imag) : m_real(real), m_imag(imag) {} double real() const { return m_real; } double imag() const { return m_imag; } private: double m_real; double m_imag; }; bool operator==(const Complex& lhs, const Complex& rhs) { return lhs.real() == rhs.real() && lhs.imag() == rhs.imag(); } template<typename T> bool isEqualTo(const T& a, const T& b) { return a == b; } int main() { std::cout << std::boolalpha; std::cout << isEqualTo(Complex(1.0, 2.0), Complex(1.0, 2.0)) << std::endl; std::cout << isEqualTo(Complex(1.0, 2.0), Complex(3.0, 4.0)) << std::endl; return 0; } ``` Output: ``` true false ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值