1138 Postorder Traversal(25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

只要求输出后序的第一个那么分三种情况讨论

1 就一个根结点,直接输出

2 在右子树,根结点的位置都在第一个,遍历两个序列不一样的,中序的位置既是后序第一个,全部一样就输出最后一个

3 在左子树,直接输出先序左子树最后一个

#include<cstdio>
#include<fstream>
const int maxn=50010;
int a[maxn]={0};
int b[maxn]={0};

int main(){
	int n;
//	freopen("d://in.txt","r",stdin);
	scanf("%d", &n);
	for(int i=0; i<n; i++){
		scanf("%d", &a[i]);
	}
	for(int i=0; i<n; i++){
		scanf("%d", &b[i]);
	}
	int x=a[0];
	
	for(int i=0; i<n; i++){
		if(x==b[i]){
			x=i;
			break;
		}
	}
	
	bool flag=false;
	if(n==1)printf("%d", a[0]);
	else if(x==0){
		for(int i=0; i<n; i++){
			if(a[i]!=b[i]){
				printf("%d", b[i]);
				flag=true;
				break;
			}
		}
		if(flag==false) printf("%d", b[n-1]);
	}
	else printf("%d", a[x]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值