Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <231). It is guaranteed that the number of digits of Z is an even number.
Output Specification:
For each case, print a single line Yes
if it is such a number, or No
if not.
Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No
#include<cstdio>
#include<cstring>
double check(char z[]){
double a=0, b=0;
double c=0;
int len=strlen(z);
for(int i=0; i<len/2; i++){
a*=10;
a+=z[i]-'0';
}
for(int i=len/2; i<len; i++){
b*=10;
b+=z[i]-'0';
}
for(int i=0; i<len; i++){
c*=10;
c+=z[i]-'0';
}
c=c/(a*b);
return c;
}
int main(){
int n;
scanf("%d", &n);
for(int i=0; i<n; i++){
double sum=0;
double temp=0;
char z[11]={0};
scanf("%s", z);
temp=check(z);
sum=temp-(int)temp;
if(sum>0) printf("No\n");
else printf("Yes\n");
}
return 0;
}