Encoding

Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
 
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 
Output
For each test case, output the encoded string in a line.
 
Sample Input
 
 
2 ABC ABBCCC
 
Sample Output
 
  

ABC A2B3C


就是有几个英文输出几个数字在英文前面 1不输出


交了好几次都wa  最后删除了我的排序部分结果正确了... 我很蒙蔽 我也不知道为什么 排序了居然提交还wa了

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 10010
using namespace std;
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		char a[M];
		scanf("%s",a);
		int i,k,b=-1;
		for(i=0;i<strlen(a);i++)
		{
			if(a[i]!=a[i+1])
			{
				if(i-b>1)
					printf("%d",i-b);
				b=i;
				printf("%c",a[i]);
			}
		}
		printf("\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值