Factorial

Problem Description
The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically. 

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high even for a relatively small N. 

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function. 

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1 < N2, then Z(N1) <= Z(N2). It is because we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently. 

 

Input
There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.
 

Output
For every number N, output a single line containing the single non-negative integer Z(N).
 

Sample Input
 
 
6 3 60 100 1024 23456 8735373
 

Sample Output
 
 
0 14 24 253 5861 2183837

 


题目大意是 输入一个n 计算n!之后 尾数有多少个0   已知0是由2*5得到的 而得到5的过程中必定有两个2,比如1 2 3 4 5 中 有2 和 4两个偶数 所以只用知道有多少个5因子的存在 便有多少个0

for

example.1: n=25 1~25中 有25/5=5个能被5整除的数 又有 25/25个被25整除的数 这样我们得到6个5因子(原本已经除以5了 所以25有两个因子减去之前重复计算的 变成了1个 以此类推)

example.2: n=125 1~125中 有125/5个能被5整除的数 又有125/25个被25整除的数 还有125/125=1个被125整除的 即31个因子


其实已知 x/y=n 便是1~x中有n个能被y整除的数 所以可以一直除以5^n来解决尾数问题



#include<stdio.h>
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n;
		scanf("%d",&n);
		int i=5,z=0;
		while(i<=n)
		{
			z+=n/i;
			i*=5;
		}
		printf("%d\n",z);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值