HDU - 1052 Tian Ji -- The Horse Racing(简单贪心)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25569    Accepted Submission(s): 7528


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0
 

Source
 


错了好多次,每次都考虑的不周全,要想好贪心策略。

思路:

CASE 1.如果田忌最慢的马比齐王最慢的马快,那就直接将这两个马相比,win++

CASE 2.如果田忌最快的马比齐王最快的马快,那也直接将这两个马相比,win++

CASE 3.如果田忌最慢的马比齐王最慢的马慢或一样快,那田忌就要用他最慢的马去和齐王最快的马比,win--(注意如果一样快不用win--)


#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn = 1005;
bool book[maxn];
int main(void)
{
    //freopen("hdu1052.txt", "r", stdin);
    int n, i, j, tian[maxn], king[maxn];
    while(cin >> n, n)
    {
        memset(book, 0, sizeof(book));
        for(i = 0; i < n; i++) cin >> tian[i];
        for(i = 0; i < n; i++) cin >> king[i];
        sort(tian, tian+n);
        sort(king, king+n);
        int win = 0, tianSlow = 0, kingSlow = 0, tianFast = n-1, kingFast = n-1;
        for(i = 0; i < n; i++)
        {<span style="white-space:pre">	</span>
            if(tian[tianSlow] > king[kingSlow]) { win++; tianSlow++; kingSlow++; }<span style="white-space:pre">	</span>//CASE 1
            else if(tian[tianFast] > king[kingFast]) { win++; tianFast--; kingFast--; }<span style="white-space:pre">	</span>//CASE 2
            else if(tian[tianSlow] <= king[kingSlow] && tian[tianSlow] < king[kingFast]) { tianSlow++; kingFast--; win--; }<span style="white-space:pre">	</span>//CASE 3
            else continue;
        }
        cout << win*200 << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值