5-12 关于堆的判断 (25分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N\le 1000)和M\le 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000][10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T



没有手写过堆 不会写...也可以用STL的heap来实现, 还是heap实现起来方便多了。

#include<bits/stdc++.h>
using namespace std;

vector<int>heap;
int n, m;

int find(int a)
{
    return distance(heap.begin(), find(heap.begin(), heap.end(), a));   //找a到顶的距离,也就是他的对应下标
}

int main(void )
{
    scanf("%d%d", &n, &m);
    while(n--)
    {
        int t;
        scanf("%d", &t);
        heap.push_back(t);
        make_heap(heap.begin(), heap.end(), greater<int>());    //小顶堆
    }
    getchar();
    while(m--)
    {
        string q;
        getline(cin, q);
        if(q[q.length() - 1] == 't')
        {
            int a;
            stringstream ss(q);
            ss >> a;
            if (heap[0] == a) printf("T\n");
            else printf("F\n");
        }
        else if(q[q.length() - 1] == 's')
        {
            int a, b;
            string temp;
            stringstream ss(q);
            ss >> a >> temp >> b;
            int pos_a = find(a);
            int pos_b = find(b);    //根是0,所以要加1
            pos_a++; pos_b++;
            if(pos_a / 2 == pos_b / 2) // /2是找父亲,如果父亲相同就是兄弟
                printf("T\n");
            else
                printf("F\n");
        }
        else
        {
            stringstream ss(q);
            int a, b;
            string temp;
            ss >> a >> temp >> temp;
            if(temp[0] == 't')
            {
                ss >> temp >> temp >> b;
                int pos_a = find(a);
                int pos_b = find(b);
                if(pos_b == pos_a * 2 + 1 || pos_b == pos_a * 2 + 2)
                    printf("T\n");
                else
                    printf("F\n");
            }
            else if(temp[0] == 'a')
            {
                ss >> temp >> temp >> b;
                int pos_a = find(a);
                int pos_b = find(b);
                if(pos_a == pos_b * 2 + 1 || pos_a == pos_b * 2 + 2)
                    printf("T\n");
                else
                    printf("F\n");
            }
        }
    }
    return 0;
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值