pta 5-1 关于堆的判断 (25分)

5-1 关于堆的判断 (25分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the root:x是根结点;
  • x and y are siblings:x和y是兄弟结点;
  • x is the parent of y:x是y的父结点;
  • x is a child of y:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤1000)和M (≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <functional>
using namespace std;

vector<int> v;

int Find(int a) {//查找对应元素值的下标
    return find(v.begin()+1, v.end(), a)-v.begin();
}

int main(int argc, char const *argv[]) {
    int n, m, a, b;
    v.push_back(0);//0坐标用掉,这样比较方便
    //父亲结点就是i / 2   儿子结点2 * i  or 2 * i + 1
    char s[100], tmp[4];
    scanf("%d %d", &n, &m);
    for(int i = 0; i < n; ++i) {
        scanf("%d", &a);
        v.push_back(a);
        push_heap(v.begin()+1, v.end(), greater<int>());//对加入的元素构造最小堆
    }
    scanf("%*c");
    while(m--) {
        gets(s);
        if(s[strlen(s) - 1] == 't') {
            sscanf(s, "%d", &a);//提取字符串里面的数字
            if(v[1] == a) printf("T\n");//如果是根结点
            else printf("F\n");
        }
        else if(s[strlen(s) - 1] == 's') {
            sscanf(s, "%d %*s %d", &a, &b);
            a = Find(a);
            b = Find(b);
            if(a/2 == b/2) printf("T\n");//兄弟结点
            else printf("F\n");
        }
        else {
            sscanf(s, "%d %*s %s %*s %*s %d", &a, tmp, &b);
            a = Find(a);
            b = Find(b);
            if(!strcmp(tmp, "the")) {
                if(a == b/2) printf("T\n");//a是b的父亲结点
                else printf("F\n");
            }
            else {
                if(a/2 == b) printf("T\n");//a是b的儿子结点
                else printf("F\n");
            }
        }
    }

    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值