Error Correction

时间限制: 1 Sec   内存限制: 64 MB

题目描述

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property: 
1 0 1 0

0 0 0 0

1 1 1 1

0 1 0 1

The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2. 
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt. 

输入

The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

输出

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".

样例输入

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

样例输出

OK
Change bit (2,3)
Corrupt
关于这个题判断是十分简单的只要一重遍历就可以判断是不是“ok”,然后对于之后的改变一个数判断是不是变成“ok”的情况,显然可知不能每个数都变一变,之前试过一次暴力把每个数都改一下再判断,结果对于程序来说,时间复杂度上了好几个台阶,这时候可以把横行,数列的奇数值列一下,如果有两个行或两个列及以上为奇数则直接输出“Corrupt”就好了,把行和列为奇数的那个点找到改一下就可以了。

怎么说,这个题没有什么难的地方,只是注意一下代码有没有打错的地方就好了。(之前因为打错了个变量调了半天,果然打代码是需要视力的QWQ)

#include<iostream>
using namespace std;
int main (){
	int n;
	while (cin>>n&&n!=0){
	int a[100][100]={0};
	int q[100]={0};
	int w[100]={0};
	for (int i=0;i<n;i++)
		for (int j=0;j<n;j++){
			cin>>a[i][j];
			q[i]+=a[i][j];
		}
	for (int j=0;j<n;j++)
		for (int i=0;i<n;i++)
			w[j]+=a[i][j];
	int c=0;
	for (int i=0;i<n;i++){
		if (q[i]%2==0)	c++;
		if (w[i]%2==0)	c++;
	}
	if (c==2*n)	cout<<"OK"<<endl;
	else {
	int e[100]={0};
	int d=0;
	int r[100]={0};
	int f=1;
	for (int i=0;i<n;i++){
		if (q[i]%2!=0)	{
			d=i;
		}
		if (w[i]%2!=0)	{
			f=i;
		}
	}
	if(a[d][f]==0)	{
		q[d]++;
		w[f]++;
	}
	if(a[d][f]==1)	{
		q[d]--;
		w[f]--;
	}
	c=0;
	for (int i=0;i<n;i++){
		if (q[i]%2==0)	c++;
		if (w[i]%2==0)	c++;
	}
	if (c==2*n)	
	cout<<"Change bit ("<<d+1<<","<<f+1<<")"<<endl;
	else 
	cout<<"Corrupt"<<endl;
		
	    }
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值