AndroidStudio对M1芯片的兼容

1. M1版本AndroidStudio下载

1.1 下载说明

官方的下载链接

在同意协议后,可以看到各个预览版本和正式版本的链接,在里面可以找到适配了M1芯片的版本(标记有Apple Silicon的版本)。

1.2 适配情况及版本推荐

目前最新的适配了M1的是AndroidStudio白狐和大雄峰的预览版。

我使用的是白狐,刚开始使用,没有什么问题,把工程的编译时间从20分钟降低到了6分钟,界面的话也清爽了很多。

2. M1版本的适配问题及解决方案(白狐版本)

2.1 JDK问题

问题描述

白狐预览版下载完成后,运行之前的项目,发现报错。(具体报错忘记截图了,很明显可以看出是JDK报错)

原因分析

由于默认选择了其内部自带的JDK版本,这个版本的JDK应该还没有对M1进行适配,会出现编译失败的问题。

解决办法

安装1.8版本的JDK,并修改AndroidStudio中的JDK路径。

2.2 Gradle的Task消失的问题

问题描述

在Gradle的侧边栏,展开后发现没有Tasks的内容了。

原因分析

该版本默认关闭了Gradle的Tasks同步和展示。

解决办法

打开AndroidStudio->Prefrence->Experimental

关闭勾选的"Do not build Gradle task list …"

2.3 Terminal无法显示的问题

问题描述

在最新的白狐M1版本中,无法在AndroidStudio中使用命令行,会报异常"Can’t open local terminal"

原因分析

软件Bug,工程师搞出来的奇怪问题,具体有人提Issue

解决办法

(我使用的方式)方式一:如果本地有IDEA的M1版本,直接把IDEA.app/Contents/lib/pty4j-native/darwin/ 的文件拷贝到一样路径的AndroidStudio的路径下面就可以了。

方式二:Issues里面提到了,可以运行下面的指令

git clone https://github.com/JetBrains/pty4j.git
cd pty4j/native
clang -fPIC -c *.c
clang -shared -o libpty.dylib *.o
cp libpty.dylib "/Applications/Android Studio Preview.app/Contents/lib/pty4j-native/darwin/"
  • 2
    点赞
  • 4
    收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:编程工作室 设计师:CSDN官方博客 返回首页
评论

打赏作者

ICodeMan

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值