HDU - 1237

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。 
Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。 
Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。 
Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0
Sample Output
3.00
13.36
#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
using namespace std;
int main()
{
    string s;
    int flag;
    while(getline(cin,s))
    {
        if(s.size()==1)break;
        flag = 1;
        stringstream stream(s);
        double num;
        char op = ' ';
        stack<char> sop;
        stack<double> snum;
        while(1)
        {
            if(flag)
            {
               stream >> num;
                if(op =='*'||op == '/')
                {
                    double num1 = snum.top();
                    snum.pop();
                    if(op=='*')
						num1 = num * num1;
                    else
						num1 = num1 / num;
                    snum.push(num1);
                }
                else 
					snum.push(num);
                flag=0;
            }
            else
            {
                if(stream>>op);
                else break;
                if(op=='+'||op=='-')
                {
                    double num1,num2;
                    char c;
                    if(!sop.empty())
                    {
                        c=sop.top(),sop.pop();
                        num2=snum.top(),snum.pop();
                        num1=snum.top(),snum.pop();
                        if(c=='+')num1+=num2;
                        else num1-=num2;
                        snum.push(num1);
                    }
                    sop.push(op);
                }
                flag=1;
            }
        }
        while(!sop.empty())
        {
            op=sop.top(),sop.pop();
            double num1,num2;
            num2=snum.top(),snum.pop();
            num1=snum.top(),snum.pop();
            if(op=='+')
				num1+=num2;
            else 
				num1-=num2;
            snum.push(num1);
        }
        printf("%.2lf\n",snum.top());
    }
    return 0;
}

#include<iostream>
#include<stack>
#include<cstring>
#include<cstdio>
#include<sstream>
#include<iomanip>
#include<string>
using namespace std;
int main() 
{	
	char op;
	double num,temp;
	while(scanf("%lf",&num))
	{
		stack<double> sum;
		op = getchar();
		if(num == 0 && op == '\n')break;
		sum.push(num);
		while(1)
		{
			scanf("%c %lf", &op, &num);
			switch (op)
			{
			case '+':
				sum.push(num);
				break;
			case '-':
				sum.push(-num);
				break;
			case '*':
				temp = sum.top();
				sum.pop();
				sum.push(temp*num);
				break;
			case '/':
				temp = sum.top();
				sum.pop();
				sum.push(temp/num);
				break;
			}
			if(getchar() == '\n')break;
		}
		double ans = 0;
		while(!sum.empty())
		{
			ans += sum.top();
			sum.pop();
		}
		printf("%.2lf\n",ans);
	}

		
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值