UVA - 133

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour RhinocerosParty has decided on the following strategy. Every day all dole applicants will be placed in a largecircle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counterclockwiseup to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise,one labour official counts off k applicants, while another official starts from N and moves clockwise,counting m applicants. The two who are chosen are then sent off for retraining; if both officials pickthe same person she (he) is sent off to become a politician. Each official then starts counting againat the next available person and the process continues until no-one is left. Note that the two victims(sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person alreadyselected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0,0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set ofthree numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Eachnumber should be in a field of 3 characters. For pairs of numbers list the person chosen by the counterclockwiseofficial first. Separate successive pairs (or singletons) by commas (but there should not be atrailing comma).Note: The symbol ⊔ in the Sample Output below represents a space.

Sample Input

10 4 30 0 0

Sample Output

␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7

(␣␣这是两个空格)

#include<iostream>
#include<cstdio>
using namespace std;
 int main()
 {
 	int N, k, m;
 	while(~scanf("%d %d %d", &N, &k, &m))
 	{
 		if(N == 0||k == 0||m==0)break;
 		int f[30] = {0}, num = 0, km = 0, mm = 0, i = 1, j = N, flag = N;
 		while(num != N)
 		{
 			while(1)
 			{
 				if(i > N)
 					i = 1;
 				if(f[i] != 1)
 					++km;
 				if(km == k)
 				{
 					km = 0;
 					++num;
 					break;
				 }
				 ++i;
			 }
			 while(1)
 			{
 				if(j < 1)
 					j = N;
 				if(f[j] != 1)
 					++mm;
 				if(mm == m)
 				{
 					mm = 0;
 					f[j] = 1;
					f[i] = 1;
					if(i != j)
 						++num;
 					break;
				 }
				 --j;
			 }
			 if(i == j)
			 {
			 	printf("%3d", i);
			 	--flag;
			 }
			 else if(i != j)
			 {
			 	printf("%3d%3d",i,j);
			 	flag -= 2;
			 }
			 if(flag)
			 	printf(",");
 		}
 		printf("\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值