HDU 3415 Max Sum of Max-K-sub-sequence(求长度不超过K的最大区间和)

http://acm.hdu.edu.cn/showproblem.php?pid=3415

Problem Description
Given a circle sequence A[1],A[2],A[3]……A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.

Sample Input
4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1

Sample Output
7 1 3
7 1 3
7 6 2
-1 1 1


经典单调队列问题,先将区间前缀和求出来,然后维护最小的单调队列。
每次判断的时候看是否在K长度范围之内即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long LL;
const int N = 1e5 + 100;
const LL INF = (LL)N*N;
LL f[N*2],que[N*2],arr[N*2];
int pos[N*2];

int main()
{
        int T;
        scanf("%d",&T);
        while(T--)
        {
                int n,k,x,idl,idr;
                scanf("%d%d",&n,&k);
                int ln = n;
                for(int i=1;i<=n;i++) scanf("%I64d",&arr[i]),f[i]=f[i-1]+arr[i];
                for(int i=1;i<k;i++) f[i+n] = f[i+n-1] + arr[i];
                n += k-1;

                LL ans = -INF;  
                int head = 1, tail = 0;
                for(int i=0;i<=n;i++)
                {
                        while(head <= tail && pos[head]+k<i) head++;
                        if( head<=tail && ans < f[i]-que[head]) 
                                ans = f[i]-que[head],idl = pos[head]+1,idr = i;

                        while(head <= tail && que[tail]>f[i]) tail--;
                        que[++tail] = f[i];
                        pos[tail] = i;
                }
                if(idl>ln)  idl -= ln;
                if(idr>ln)  idr -= ln;
                printf("%I64d %d %d\n",ans,idl,idr);
        }
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值