hdu Max Sum of Max-K-sub-sequence(单调队列)

Problem Description

Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.

Sample Input

4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1

Sample Output

7 1 3
7 1 3
7 6 2
-1 1 1
 
 
题意:给定n个数组成的循环序列,求最大的连续子段和
单调队列简单题,由于原序列是一个环,在序列后面复制一段再处理会更方便一点

代码:
#include<stdio.h>
int a[200010],sum[200010];   // a记录队列中元素位置,sum记录前i项和
int l,r,t,n,k,p,q,max;
int main()
{
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&n,&k);
        for (int i=1;i<=n;i++)
        {
            scanf("%d",&sum[i]);
            sum[i]+=sum[i-1];
        }
        for (int i=n+1;i<=n+k;i++)
            sum[i]=sum[n]+sum[i-n];
        l=0;r=-1;max=-2000000000;
        for (int i=1;i<=n+k;i++)
        {
            while (l<=r&&sum[a[r]-1]>sum[i-1])
                      r--;
               a[++r]=i;
            while (i-a[l]>=k)
                     l++;
             if (sum[i]-sum[a[l]-1]>max)
            {
                max=sum[i]-sum[a[l]-1];
                p=a[l];
                q=i;
            }
        }

        printf("%d %d %d\n",max,p,q>n?q-n:q);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值