/*
*
*Problem Description
*统计给定的n个数中,负数、零和正数的个数。
*
*
*Input
*输入数据有多组,每组占一行,每行的第一个数是整数n(n<100),表示需要统计的数值的个数,然后是n个实数;如果n=0,则表示输入结束,该行不做处理。
*
*
*Output
*对于每组输入数据,输出一行a,b和c,分别表示给定的数据中负数、零和正数的个数。
*
*
*Sample Input
*6 0 1 2 3 -1 0
*5 1 2 3 4 0.5
*0
*
*
*Sample Output
*1 2 3
*0 0 5
*
*
*Author
*lcy
*
*
*Source
*C语言程序设计练习(二)
*
*
*Recommend
*JGShining
*
*/
#include<iostream>
using namespace std;
int main() {
int n, num_zero, num_positive, num_negative;
double x;
while (cin >> n) {
if (n == 0)break;
num_zero = 0, num_positive = 0, num_negative = 0;
for (int i = 0; i < n; i++) {
cin >> x;
if (x > 0)
num_positive++;
else if (x == 0)
num_zero++;
else
num_negative++;
}
printf("%d %d %d\n", num_negative, num_zero, num_positive);
}
system("pause");
return 0;
}
hdu_problem_2008_数值统计
最新推荐文章于 2022-12-06 18:31:46 发布